Bug 991379 - virt-who is missing dependency on python-uuid and python-hashlib
virt-who is missing dependency on python-uuid and python-hashlib
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: virt-who (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Radek Novacek
Entitlement Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-02 05:51 EDT by Radek Novacek
Modified: 2016-11-30 19:31 EST (History)
4 users (show)

See Also:
Fixed In Version: virt-who-0.9-1.el5
Doc Type: Bug Fix
Doc Text:
no docs needed
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-09-15 20:29:18 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Radek Novacek 2013-08-02 05:51:55 EDT
Uuid module for python was not part of python until python-2.5. There is python-2.4 in RHEL-5 and uuid module is in the separate package (python-uuid).

Runtime dependency needs to be added to virt-who package.
Comment 1 Radek Novacek 2013-08-02 06:46:02 EDT
Dependency on python-hashlib is also missing.
Comment 2 RHEL Product and Program Management 2014-01-22 11:28:43 EST
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 3 Radek Novacek 2014-03-13 09:40:51 EDT
Fixed in virt-who-0.9-1.el5.
Comment 5 Liushihui 2014-04-24 05:45:20 EDT
As there are no packages python-uuid and python-hashlib in RHEL-5 
that virt-who can use, so Radek has made an workaround using openssl/uuidgen packages. According to Radek's suggestion, we can verify that the bug is fixed when virt-who Hyper-V support works.

Verified it on virt-who-0.9-2.el5

Steps to verify:
1.Configure virt-who run at HyperV mode.
#vim /etc/sysconfig/virt-who, Update as the following:
VIRTWHO_DEBUG=1
VIRTWHO_INTERVAL=5
VIRTWHO_HYPERV=1

VIRTWHO_HYPERV_OWNER=ACME_Corporation
VIRTWHO_HYPERV_ENV=Library
VIRTWHO_HYPERV_SERVER=10.66.128.173
VIRTWHO_HYPERV_USERNAME=administrator
VIRTWHO_HYPERV_PASSWORD=qwer1234P
2.Register to SAM server
#subscription-manager register --username=admin --password=admin
3.Restart virt-who service
# service virt-who restart
4.Monitor the rhsm.log file, 
#tail -f /var/log/rhsm/rhsm.log

2014-04-24 03:32:53,067 [WARNING]  @virt-who.py:515 - Listening for events is not available in VDSM, ESX, RHEV-M or Hyper-V mode
2014-04-24 03:32:53,457 [DEBUG]  @hyperv.py:172 - Hyper-V url: http://10.66.128.173:5985/wsman
2014-04-24 03:32:53,457 [DEBUG]  @virt-who.py:528 - Virt-who is running in hyperv mode
2014-04-24 03:32:53,457 [DEBUG]  @virt-who.py:535 - Starting infinite loop with 5 seconds interval and event handling
2014-04-24 03:32:53,461 [DEBUG]  @hyperv.py:222 - Using NTLM authentication
2014-04-24 03:32:53,527 [DEBUG]  @hyperv.py:249 - NTLM authentication successful
2014-04-24 03:32:54,409 [DEBUG]  @subscriptionmanager.py:89 - Sending update in hosts-to-guests mapping: {'60D30E26-6409-0EA6-6C0E-0ED223510F02': ['A9204F8B-0312-DD4F-8286-819B6CA7E554']}
2014-04-24 03:33:08,414 [INFO]  @virt-who.py:217 - Created host: 4e44af87-e7f0-427e-b494-7116cfcd7a8d with guests: [A9204F8B-0312-DD4F-8286-819B6CA7E554]
2014-04-24 03:33:13,416 [DEBUG]  @hyperv.py:222 - Using NTLM authentication
2014-04-24 03:33:13,430 [DEBUG]  @hyperv.py:249 - NTLM authentication successful
2014-04-24 03:33:14,267 [DEBUG]  @subscriptionmanager.py:89 - Sending update in hosts-to-guests mapping: {'60D30E26-6409-0EA6-6C0E-0ED223510F02': ['A9204F8B-0312-DD4F-8286-819B6CA7E554']}

Result: virt-who send the right host/guest association to SAM server, Therefore, verify it on virt-who-0.9-2.el5.
Comment 7 errata-xmlrpc 2014-09-15 20:29:18 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1206.html

Note You need to log in before you can comment on or make changes to this bug.