Bug 991382 - fedup 18->19 after reboot fails: failed to open file /sysroot/var/lib/fedora-upgrade/media/Packages/...
fedup 18->19 after reboot fails: failed to open file /sysroot/var/lib/fedora-...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: fedup (Show other bugs)
18
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-02 06:09 EDT by Juhani Jaakola
Modified: 2014-02-05 17:13 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-02-05 17:13:27 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/upgrade.log (586.44 KB, text/x-log)
2013-08-02 06:09 EDT, Juhani Jaakola
no flags Details

  None (edit)
Description Juhani Jaakola 2013-08-02 06:09:19 EDT
Created attachment 781907 [details]
/var/log/upgrade.log

Description of problem:
I try to upgrade Fedora 18 to 19 with command:
fedup --iso /home/jj/Download/Fedora-19-i386-DVD.iso

After the reboot I see a lot of messages like the following:
Warning: failed to open file /sysroot/var/lib/fedora-upgrade/media/Packages/a/avahi-gobject-0.6.31-11.fc19.i686.rpm
Warning: couldn't add media/Packages/a/avahi-gobject-0.6.31-11.fc19.i686.rpm to the transaction

After that the system reboots again to Fedora 18, so the upgrade fails.

In /var/log/upgrade.log I can see the following errors (among others):

Aug 02 06:28:01 kamu.jsoft.fi systemd[1]: var.mount: Directory /var to mount over is not empty, mounting anyway.
Aug 02 06:28:01 kamu.jsoft.fi systemd[1]: system\x2dupgrade-media.mount: Directory /system-upgrade/media to mount over is not empty, mounting anyway.
Aug 02 06:28:01 kamu.jsoft.fi mount[449]: mount: mount point /system-upgrade/media does not exist
Aug 02 06:28:01 kamu.jsoft.fi systemd[1]: system\x2dupgrade-media.mount mount process exited, code=exited status=32
Aug 02 06:28:01 kamu.jsoft.fi systemd[1]: Failed to mount Upgrade Media.
Aug 02 06:28:01 kamu.jsoft.fi systemd[1]: Unit system\x2dupgrade-media.mount entered failed state.

I updated my Fedora 18 system to the latest packages before fedup.

Version-Release number of selected component (if applicable):
kernel-3.9.11-200.fc18.i686
fedup-0.7.3-4.fc18.noarch


How reproducible:
I tried two times, both attempts failed in the same way.

Steps to Reproduce:
1. fedup --iso /home/jj/Download/Fedora-19-i386-DVD.iso
2. reboot

Actual results:
After the reboot, lots of errors (failed to open file...), reboot back to Fedora 18

Expected results:
Fedora 19 up and running!

Additional info:
Fedora 18 was upgraded using fedup from Fedora 17
Comment 1 Will Woods 2013-12-06 17:11:08 EST
What's var.mount? Can you attach your /etc/fstab and/or the output of 'mount'?
Comment 2 Juhani Jaakola 2013-12-06 17:36:14 EST
When I tried fedup several times, eventually it managed to perform the upgrade. I encountered this problem on several PCs. Usually it was the third or fourth time it succeeded. So I don't have any Fedora 18 systems any more!

After one failed fedup I booted that PC with a Live CD and mounted the root partition on the hard disk. I noticed that mount point /var was non-empty! So somehow Fedora 18 could mount /var anyway and fedup can succeed as well if repeated many times!

I don't remember any more what files /var contained, but the date was old. Perhaps they were left there when I upgraded from Fedora 17 to Fedora 18, the dates of the files were about that age.
Comment 3 Fedora End Of Life 2013-12-21 09:25:17 EST
This message is a reminder that Fedora 18 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 18. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '18'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 18's end of life.

Thank you for reporting this issue and we are sorry that we may not be 
able to fix it before Fedora 18 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior to Fedora 18's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 4 Fedora End Of Life 2014-02-05 17:13:27 EST
Fedora 18 changed to end-of-life (EOL) status on 2014-01-14. Fedora 18 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.