Bug 991405 - Fail to register to SAM with error "undefined local variable or method `attrs' "
Fail to register to SAM with error "undefined local variable or method `attrs' "
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: candlepin (Show other bugs)
1.3
Unspecified Unspecified
unspecified Severity high
: rc
: ---
Assigned To: Katello Bug Bin
SAM QE List
:
Depends On:
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-08-02 07:25 EDT by qianzhan
Modified: 2013-10-01 07:16 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-01 07:16:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
'rhsm.log' (14.87 KB, text/plain)
2013-08-02 07:27 EDT, qianzhan
no flags Details
'katello-debug-20130805012931.tar.gz' (97.63 KB, application/x-gzip)
2013-08-05 01:50 EDT, qianzhan
no flags Details

  None (edit)
Description qianzhan 2013-08-02 07:25:37 EDT
Description of problem:
Fail to register to SAM with error "undefined local variable or method `attrs' "

Version-Release number of selected component (if applicable):
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-1.4.3-3.el6sat.noarch
katello-cli-common-1.4.3-3.el6sat.noarch
katello-common-1.4.3-4.el6sam_splice.noarch
katello-configure-1.4.4-2.el6sat.noarch
katello-glue-candlepin-1.4.3-4.el6sam_splice.noarch
katello-glue-elasticsearch-1.4.3-4.el6sam_splice.noarch
katello-headpin-1.4.3-4.el6sam_splice.noarch
katello-headpin-all-1.4.3-4.el6sam_splice.noarch
katello-selinux-1.4.4-2.el6sat.noarch
signo-katello-0.0.10-2.el6sat.noarch
candlepin-0.8.19-1.el6sam.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
candlepin-selinux-0.8.19-1.el6sam.noarch
candlepin-tomcat6-0.8.19-1.el6sam.noarch
thumbslug-0.0.32-1.el6sam.noarch
thumbslug-selinux-0.0.32-1.el6sam.noarch
subscription-manager-1.8.15-1.el5
subscription-manager-firstboot-1.8.15-1.el5
subscription-manager-gui-1.8.15-1.el5

How reproducible:
Always

Steps to Reproduce:
1.Prepare to register to SAM
[root@dhcp-65-112 ~]# cat /etc/rhsm/rhsm.conf
hostname = samserv.redhat.com
baseurl= https://samserv.redhat.com:8088
[root@dhcp-65-112 ~]# rpm -ivh http://10.66.13.158/pub/candlepin-cert-consumer-samserv.redhat.com-1.0-1.noarch.rpm
Retrieving http://10.66.13.158/pub/candlepin-cert-consumer-samserv.redhat.com-1.0-1.noarch.rpm
Preparing...                ########################################### [100%]
   1:candlepin-cert-consumer########################################### [100%]

2.Register to SAM
[root@dhcp-65-112 ~]# subscription-manager register
Username: admin
Password: 
undefined local variable or method `attrs' for #<System:0x000000088004a0>

Actual results:
Fail to register to SAM with error "undefined local variable or method `attrs' for #<System:0x000000088004a0>"

Expected results:
Register to SAM successfully.

Additional info:
The rhsm.log file is attached as 'rhsm.log'
Comment 1 qianzhan 2013-08-02 07:27:05 EDT
Created attachment 781941 [details]
'rhsm.log'
Comment 2 Tom McKay 2013-08-02 07:39:23 EDT
If possible, please attach the katello-debug output run on the SAM server. This will contain all the necessary logs to help determine the cause.
Comment 3 qianzhan 2013-08-05 01:50:35 EDT
Created attachment 782655 [details]
'katello-debug-20130805012931.tar.gz'
Comment 4 qianzhan 2013-08-05 01:51:23 EDT
(In reply to Tom McKay from comment #2)
> If possible, please attach the katello-debug output run on the SAM server.
> This will contain all the necessary logs to help determine the cause.

Please see attachment 'katello-debug-20130805012931.tar.gz'.
Comment 5 Tom McKay 2013-08-05 07:55:37 EDT
Fixed in 1.4.3-5
Comment 6 qianzhan 2013-08-08 07:24:04 EDT
(In reply to Tom McKay from comment #5)
> Fixed in 1.4.3-5

Hi Tom,

I have verified this bug against SAM-1.3.0-RHEL-6-20130808.0, and the registration is all right. Please move the status to 'ON_QA' if you think it is really fixed.

The following are packages included in SAM-1.3.0-RHEL-6-20130808.0:

katello-candlepin-cert-key-pair-1.0-1.noarch
katello-certs-tools-1.4.2-2.el6sat.noarch
katello-cli-1.4.3-5.el6sat.noarch
katello-cli-common-1.4.3-5.el6sat.noarch
katello-common-1.4.3-6.el6sam_splice.noarch
katello-configure-1.4.4-2.el6sat.noarch
katello-glue-candlepin-1.4.3-6.el6sam_splice.noarch
katello-glue-elasticsearch-1.4.3-6.el6sam_splice.noarch
katello-headpin-1.4.3-6.el6sam_splice.noarch
katello-headpin-all-1.4.3-6.el6sam_splice.noarch
katello-selinux-1.4.4-2.el6sat.noarch
signo-katello-0.0.10-2.el6sat.noarch
candlepin-0.8.19-1.el6sam.noarch
candlepin-scl-1-5.el6_4.noarch
candlepin-scl-quartz-2.1.5-5.el6_4.noarch
candlepin-scl-rhino-1.7R3-1.el6_4.noarch
candlepin-scl-runtime-1-5.el6_4.noarch
candlepin-selinux-0.8.19-1.el6sam.noarch
candlepin-tomcat6-0.8.19-1.el6sam.noarch
thumbslug-0.0.32-1.el6sam.noarch
thumbslug-selinux-0.0.32-1.el6sam.noarch

Thanks.
Qianqian
Comment 7 qianzhan 2013-08-12 02:15:35 EDT
According to comment 6, mark this bug as 'VERIFIED'.
Comment 9 errata-xmlrpc 2013-10-01 07:16:04 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.