Bug 991423 - [vdsm] Template export fails due to missing attribute (NFS only)
[vdsm] Template export fails due to missing attribute (NFS only)
Status: CLOSED ERRATA
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm (Show other bugs)
3.3.0
x86_64 Linux
unspecified Severity urgent
: ---
: 3.3.0
Assigned To: Yeela Kaplan
Jakub Libosvar
storage
: Regression, TestBlocker
: 990884 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-02 07:51 EDT by Jakub Libosvar
Modified: 2016-02-10 12:43 EST (History)
13 users (show)

See Also:
Fixed In Version: v4.12.0
Doc Type: Bug Fix
Doc Text:
Exporting a template that had a virtual machine based on itself failed due to an attribute, safeUnlink, which had been replaced by rmFile. The reference to the safeUnlink has now been removed, so the template export succeeds.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 11:30:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
scohen: Triaged+


Attachments (Terms of Use)
Logs (5.05 MB, application/x-bzip)
2013-08-02 07:51 EDT, Jakub Libosvar
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 17173 None None None Never

  None (edit)
Description Jakub Libosvar 2013-08-02 07:51:25 EDT
Created attachment 781948 [details]
Logs

Description of problem:
Exporting template that has already a vm based on itself on export domain fails due to missing attribute:

0a70a764-da35-48e1-ac04-daa9682272d0::DEBUG::2013-08-02 04:59:58,852::utils::538::Storage.Misc.excCmd::(watchCmd) SUCCESS: <err> = []; <rc> = 0
0a70a764-da35-48e1-ac04-daa9682272d0::DEBUG::2013-08-02 04:59:58,853::volume::1139::Storage.Volume::(qemuConvert) (qemuConvert): COPY /rhev/data-center/c4b183de-e282-4a3b-9ad7-691d64c565fe/0ee606b8-b71c-44f5-b8aa-9c4dc68b43f7/images/fc6608e9-f335-413b-8f38-89c3c1e68449/bd4c21c6-cda1-44e3-9dda-46358af5b853 to /rhev/data-center/c4b183de-e282-4a3b-9ad7-691d64c565fe/90c9dae7-f760-4ced-b405-db9f8e0ed98f/images/fc6608e9-f335-413b-8f38-89c3c1e68449/bd4c21c6-cda1-44e3-9dda-46358af5b853 DONE
0a70a764-da35-48e1-ac04-daa9682272d0::INFO::2013-08-02 04:59:58,917::volume::663::Storage.Volume::(setLegality) sdUUID=90c9dae7-f760-4ced-b405-db9f8e0ed98f imgUUID=fc6608e9-f335-413b-8f38-89c3c1e68449 volUUID = bd4c21c6-cda1-44e3-9dda-46358af5b853 legality = LEGAL
0a70a764-da35-48e1-ac04-daa9682272d0::ERROR::2013-08-02 04:59:58,952::image::799::Storage.Image::(copy) Unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/storage/image.py", line 794, in copy
    destDom.templateRelink(dstImgUUID, dstVolUUID)
  File "/usr/share/vdsm/storage/fileSD.py", line 565, in templateRelink
    self.oop.fileUtils.safeUnlink(tLink)
  File "/usr/share/vdsm/storage/remoteFileHandler.py", line 284, in callCrabRPCFunction
    *args, **kwargs)
  File "/usr/share/vdsm/storage/remoteFileHandler.py", line 199, in callCrabRPCFunction
    raise err
AttributeError: 'module' object has no attribute 'safeUnlink'


0a70a764-da35-48e1-ac04-daa9682272d0::ERROR::2013-08-02 04:59:58,961::task::850::TaskManager.Task::(_setError) Task=`0a70a764-da35-48e1-ac04-daa9682272d0`::Unexpected error
Traceback (most recent call last):
  File "/usr/share/vdsm/storage/task.py", line 857, in _run
    return fn(*args, **kargs)
  File "/usr/share/vdsm/storage/task.py", line 318, in run
    return self.cmd(*self.argslist, **self.argsdict)
  File "/usr/share/vdsm/storage/securable.py", line 68, in wrapper
    return f(self, *args, **kwargs)
  File "/usr/share/vdsm/storage/sp.py", line 1747, in copyImage
    postZero, force)
  File "/usr/share/vdsm/storage/image.py", line 801, in copy
    (srcImgUUID, dstImgUUID, str(e)))
CopyImageError: low level Image copy failed: ("src image=fc6608e9-f335-413b-8f38-89c3c1e68449, dst image=fc6608e9-f335-413b-8f38-89c3c1e68449: msg='module' object has no attribute 'safeUnlink'",)



Version-Release number of selected component (if applicable):
rhevm-3.3.0-0.13.master.el6ev.noarch
vdsm-4.12.0-rc3.13.git06ed3cc.el6ev.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Have a template on nfs
2. Create a VM from the template
3. Export vm
4. Export template

Actual results:
Template export fails

Expected results:
Template export succeeds

Additional info:
Jenkins logs are attached, relevant log is vdsm.log.1.xz
Works in 3.2
Comment 2 Sergey Gotliv 2013-08-04 16:03:01 EDT
*** Bug 990884 has been marked as a duplicate of this bug. ***
Comment 5 Charlie 2013-11-27 19:28:34 EST
This bug is currently attached to errata RHBA-2013:15291. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to 
minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.
* Consequence: What happens when the bug presents.
* Fix: What was done to fix the bug.
* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes 

Thanks in advance.
Comment 6 errata-xmlrpc 2014-01-21 11:30:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0040.html

Note You need to log in before you can comment on or make changes to this bug.