Bug 99144 - libgnomeprintui22-2.2.1.3-1.src.rpm needs libgnomeprint22-devel >= 2.2.1.3 as prereq
libgnomeprintui22-2.2.1.3-1.src.rpm needs libgnomeprint22-devel >= 2.2.1.3 as...
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: libgnomeprintui22 (Show other bugs)
1.0
i586 Linux
medium Severity low
: ---
: ---
Assigned To: Owen Taylor
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-14 20:03 EDT by Ken MacFarlane
Modified: 2007-04-18 12:55 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-28 19:29:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ken MacFarlane 2003-07-14 20:03:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.2.1) Gecko/20030315

Description of problem:
rpmbuild --rebuild libgnomeprintui22-2.2.1.3-1.src.rpm fails with
libgnomeprint22-devel-2.2.1.2-2 installed, but succeeds with
libgnomeprint22-devel-2.2.1.3-2.  In the former case, rpmbuild should exit
immediately with prerequisite information.

Version-Release number of selected component (if applicable):
libgnomeprintui22-2.2.1.3-1.src.rpm

How reproducible:
Always

Steps to Reproduce:
1. rpm -U libgnomeprint22-devel-2.2.1.2-2.i586.rpm
2. rpmbuild --rebuild libgnomeprintui22-2.2.1.3-1.src.rpm

    

Actual Results:  checking for pkg-config... /usr/bin/pkg-config
checking for libgnomeprint-2.2 = 2.2.1.3        libgnomecanvas-2.0 >= 1.117.0...
Requested 'libgnomeprint-2.2 = 2.2.1.3' but version of libgnomeprint-2.2 is 2.2.1.2

configure: error: Library requirements (libgnomeprint-2.2 = 2.2.1.3    
libgnomecanvas-2.0 >= 1.117.0) not met; consider adjusting the PKG_CONFIG_PATH
environment variable if your libraries are in a nonstandard prefix so pkg-config
can find them.
error: Bad exit status from /var/tmp/rpm-tmp.42347 (%build)


Expected Results:  error: Failed build dependencies:
        libgnomeprint22-devel >= 2.2.1.3-1 is needed by libgnomeprintui22-2.2.1.3-1

Additional info:
Comment 1 Owen Taylor 2003-08-28 19:29:41 EDT
Fixed in upgrade to gnome-2.3

* Tue Aug 19 2003 Alexander Larsson <alexl@redhat.com> 2.3.1-1
- update for gnome 2.3
                                                                                

Note You need to log in before you can comment on or make changes to this bug.