Bug 991453 - crash(8): mod -S at startup generates a lot of messages making it harder to read warnings
crash(8): mod -S at startup generates a lot of messages making it harder to r...
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: retrace-server (Show other bugs)
el6
All All
low Severity low
: ---
: ---
Assigned To: Michal Toman
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-02 08:31 EDT by Mateusz Guzik
Modified: 2015-03-22 20:42 EDT (History)
5 users (show)

See Also:
Fixed In Version: retrace-server-1.10-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-22 14:25:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mateusz Guzik 2013-08-02 08:31:06 EDT
Description of problem:

When crash is executed in retrace it does 2 things:
1. analyzes the core quickly and possibly prints some warnings
2. executes crashrc which runs mod -S and that prints tons of messages

End result is that whatever warnings were initially printed are now gone from the screen and one has to scroll to check them. People interested in output printed by mod -S can always run lsmod.

So I think this should be changed so that mod -S no longer spams the terminal.

Version-Release number of selected component (if applicable):


How reproducible:

always

Steps to Reproduce:

just run retrace-server-interact <task> crash

Additional info:

Simplest thing to do is mod -S ... > /dev/null, but that may produce confusing output. Instead one can put the following:

echo Loading symbols for modules...
mod -S /cores/retrace/repos/kernel/x86_64/usr/lib/debug/lib/modules/2.6.18-274.el5 | wc -l

Effect:
[..]
Loading symbols for modules...
mod: cannot find or load object file for vmxnet module
mod: cannot find or load object file for vmxnet3 module
mod: cannot find or load object file for pvscsi module
mod: cannot find or load object file for vmci module
mod: cannot find or load object file for vxfs module
mod: cannot find or load object file for fdd module
mod: cannot find or load object file for vxportal module
mod: cannot find or load object file for vmmemctl module
mod: cannot find or load object file for vsock module
mod: cannot find or load object file for vxdmp module
mod: cannot find or load object file for vxio module
mod: cannot find or load object file for vxspec module
mod: cannot find or load object file for llt module
mod: cannot find or load object file for gab module
mod: cannot find or load object file for vxfen module
mod: cannot find or load object file for vxodm module
96
crash>

Or one could pipe mod -S to awk and produce more friendly output, whatever.
Comment 1 Michal Toman 2013-08-12 06:49:04 EDT
Fixed in upstream. I've just sent the stdout of 'mod -S' to /dev/null and after testing on a few random vmcores the output seems to be fine. The log can be later accessed with 'mod' command.

commit 2db85d77ce183c0aa05c1a0d7a3177f656d87f20
Author: Michal Toman <mtoman@redhat.com>
Date:   Mon Aug 12 12:43:26 2013 +0200

    do not show output of 'mod -S' by default
Comment 2 Fedora Update System 2013-08-21 07:36:45 EDT
retrace-server-1.10-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/retrace-server-1.10-1.el6
Comment 3 Fedora Update System 2013-08-21 15:00:55 EDT
Package retrace-server-1.10-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing retrace-server-1.10-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-11280/retrace-server-1.10-1.el6
then log in and leave karma (feedback).
Comment 4 Fedora Update System 2013-08-22 14:25:06 EDT
retrace-server-1.10-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.