Bug 991475 - Wrong users and groups in Process Definition Details
Wrong users and groups in Process Definition Details
Status: CLOSED CURRENTRELEASE
Product: JBoss BPMS Platform 6
Classification: JBoss
Component: Business Central (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity low
: ER4
: 6.0.0
Assigned To: Mauricio Salatino
Sona Mala
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-02 09:41 EDT by Zuzana Krejčová
Modified: 2016-07-31 21:07 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-08-06 16:07:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
User and Groups field (4.58 KB, image/png)
2013-08-02 09:41 EDT, Zuzana Krejčová
no flags Details
process reproducer (17.94 KB, application/xml)
2013-08-05 05:09 EDT, Zuzana Krejčová
no flags Details

  None (edit)
Description Zuzana Krejčová 2013-08-02 09:41:32 EDT
Created attachment 781968 [details]
User and Groups field

Description of problem:
If you have a process with a user task assigned to multiple users or groups, the Process Definition Details page shows only a part of that information. 

task assigned to: | User and Groups line for this task: | missing information:
------------------------------------------------------------------------------
user1,GROUP1      | GROUP1- taskname                    | user1
user1,user2       | user2- taskname                     | user1

If you assign the task to two groups only, it shows correctly.

Assignment to two groups is shown correctly. The issue is only with the value displayed, tasks are available as they should be, to the user specified in the process.

See the attached screenshot - tasks are named according to the assignments defined in the process.


Version-Release number of selected component (if applicable):
kie-wb CR1
Comment 1 Mauricio Salatino 2013-08-03 05:24:18 EDT
Hi Zuzana, can you please provide your BPMN2 process file to reproduce this issue?
Comment 2 Zuzana Krejčová 2013-08-05 05:09:34 EDT
Created attachment 782726 [details]
process reproducer
Comment 3 Mauricio Salatino 2013-08-27 06:40:42 EDT
Fixed in master: http://github.com/droolsjbpm/jbpm/commit/56dec3485

Thanks for the reproducer!
Comment 5 Mauricio Salatino 2013-09-19 15:51:36 EDT
Cherry picked into 6.0.x
Comment 9 Sona Mala 2013-10-15 08:29:21 EDT
Verified for ER4.

Multiple users are displayed and an combination of two users and two groups is displayed.

Note You need to log in before you can comment on or make changes to this bug.