Bug 991515 - Coolkey not registered in /etc/pki/nssdb/pkcs11.txt
Coolkey not registered in /etc/pki/nssdb/pkcs11.txt
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: coolkey (Show other bugs)
6.5
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Bob Relyea
Asha Akkiangady
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-02 11:49 EDT by Kai Engert (:kaie)
Modified: 2013-11-21 18:05 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-21 18:05:56 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch v1 (869 bytes, patch)
2013-08-02 11:54 EDT, Kai Engert (:kaie)
rrelyea: review+
Details | Diff

  None (edit)
Description Kai Engert (:kaie) 2013-08-02 11:49:19 EDT
Regarding the /etc/pki/nssdb directory:
- nss installs cert8+key3
- nss-sysinit installs cert9+key4

At coolkey.rpm installation time, a %post scriplet installs the coolkey pkcs#11 module into the default module, which is secmod.db

However, coolkey isn't registered into the new pkcs11.txt file used by the newer shared-db sql access mechanism.

I propose that coolkey registers itself into both places:

* I propose to change the existing scriptlet, which will use the default 
  access mechanism, to explicitly spell out the dbm: access mechanism

* I propose to add calls that will explicitly register itself using the
  sql: access mechanism.
Comment 1 Kai Engert (:kaie) 2013-08-02 11:54:39 EDT
Created attachment 782034 [details]
patch v1

possible fix, can you please review?
Comment 3 Bob Relyea 2013-08-02 12:51:22 EDT
Comment on attachment 782034 [details]
patch v1

r+
Comment 4 Kai Engert (:kaie) 2013-08-02 13:04:21 EDT
Thanks for the r+

Will you take care of getting it checked in to RHEL 6.5 git, as part of your other coolkey related work?

Second question, what about other branches? Should this get cloned for RHEL 7 at least?
Comment 5 Hubert Kario 2013-10-10 05:28:49 EDT
(In reply to Kai Engert (:kaie) from comment #4)
> Second question, what about other branches? Should this get cloned for RHEL
> 7 at least?

I have a test case that reproduces the problem, so if it is present on RHEL 7 I'll clone the bug.
Comment 7 Hubert Kario 2013-10-10 06:03:25 EDT
Small update: can't test if the problem is present on RHEL 7 as removing coolkey package doesn't unregister the module from pkcs11.txt file, see bug 1017252
Comment 8 Bob Relyea 2013-10-10 12:35:45 EDT
Hubert, bug 1017252 is the same issue. This bug is clearly fixed in the current 6.5 coolkey build. I think this bug just needs to be added to the errata, but I think it needs a QA ack for that.

bob
Comment 10 Roshni 2013-10-10 14:38:56 EDT
Works fine on RHEL 6.5.
Comment 11 Kai Engert (:kaie) 2013-10-14 17:10:07 EDT
Bob, I want to doublecheck, as you used a slightly different patch.

For the "sql" database check, you used

  modutil -dbdir sdb:%{nssdb}

I had expected you to use sql:

Did you intentionnally use sdb: ?
Comment 13 Bob Relyea 2013-11-11 20:16:50 EST
erratta updated.
Comment 14 errata-xmlrpc 2013-11-21 18:05:56 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1699.html

Note You need to log in before you can comment on or make changes to this bug.