Bug 991539 - [abrt] evolution-data-server-3.8.4-1.fc19: block_source: Process /usr/libexec/evolution-addressbook-factory was killed by signal 11 (SIGSEGV)
[abrt] evolution-data-server-3.8.4-1.fc19: block_source: Process /usr/libexec...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:f32ea0be53751ee07acb07490ab...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-02 12:54 EDT by Louis van Dyk
Modified: 2014-06-18 12:40 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-18 12:40:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (35.45 KB, text/plain)
2013-08-02 12:54 EDT, Louis van Dyk
no flags Details
File: cgroup (140 bytes, text/plain)
2013-08-02 12:54 EDT, Louis van Dyk
no flags Details
File: core_backtrace (1.83 KB, text/plain)
2013-08-02 12:55 EDT, Louis van Dyk
no flags Details
File: dso_list (3.04 KB, text/plain)
2013-08-02 12:55 EDT, Louis van Dyk
no flags Details
File: environ (1.04 KB, text/plain)
2013-08-02 12:55 EDT, Louis van Dyk
no flags Details
File: limits (1.29 KB, text/plain)
2013-08-02 12:55 EDT, Louis van Dyk
no flags Details
File: maps (105.17 KB, text/plain)
2013-08-02 12:55 EDT, Louis van Dyk
no flags Details
File: open_fds (1.46 KB, text/plain)
2013-08-02 12:55 EDT, Louis van Dyk
no flags Details
File: proc_pid_status (947 bytes, text/plain)
2013-08-02 12:55 EDT, Louis van Dyk
no flags Details
File: var_log_messages (446 bytes, text/plain)
2013-08-02 12:55 EDT, Louis van Dyk
no flags Details

  None (edit)
Description Louis van Dyk 2013-08-02 12:54:51 EDT
Description of problem:
I read and closed a message on my IMAP server.  I _might_ have moved from the sent folder to Inbox, I am not certain, but it's nothing that I don't do a 100 times a day.  Then the address books crashed.

Version-Release number of selected component:
evolution-data-server-3.8.4-1.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        /usr/libexec/evolution-addressbook-factory
crash_function: block_source
executable:     /usr/libexec/evolution-addressbook-factory
kernel:         3.10.3-300.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (7 frames)
 #0 block_source at gmain.c:2947
 #6 dbus_server_run_server at e-dbus-server.c:222
 #7 ffi_call_unix64 at ../src/x86/unix64.S:76
 #8 ffi_call at ../src/x86/ffi64.c:522
 #9 g_cclosure_marshal_generic_va at gclosure.c:1550
 #10 _g_closure_invoke_va at gclosure.c:840
 #13 e_dbus_server_run at e-dbus-server.c:414
Comment 1 Louis van Dyk 2013-08-02 12:54:56 EDT
Created attachment 782073 [details]
File: backtrace
Comment 2 Louis van Dyk 2013-08-02 12:54:59 EDT
Created attachment 782074 [details]
File: cgroup
Comment 3 Louis van Dyk 2013-08-02 12:55:03 EDT
Created attachment 782075 [details]
File: core_backtrace
Comment 4 Louis van Dyk 2013-08-02 12:55:06 EDT
Created attachment 782076 [details]
File: dso_list
Comment 5 Louis van Dyk 2013-08-02 12:55:10 EDT
Created attachment 782077 [details]
File: environ
Comment 6 Louis van Dyk 2013-08-02 12:55:13 EDT
Created attachment 782078 [details]
File: limits
Comment 7 Louis van Dyk 2013-08-02 12:55:19 EDT
Created attachment 782079 [details]
File: maps
Comment 8 Louis van Dyk 2013-08-02 12:55:22 EDT
Created attachment 782080 [details]
File: open_fds
Comment 9 Louis van Dyk 2013-08-02 12:55:25 EDT
Created attachment 782081 [details]
File: proc_pid_status
Comment 10 Louis van Dyk 2013-08-02 12:55:29 EDT
Created attachment 782082 [details]
File: var_log_messages
Comment 11 Milan Crha 2013-08-05 01:39:03 EDT
Thanks for a bug report. The backtrace doesn't show much, most threads are idle, only the main thread crashed in GLib code, which doesn't necessarily mean the issue is there, because with memory corruption (if this is it) it can strike anywhere. I see in the backtrace that you use evolution-ews, there is one soup thread for it and two delta threads, but as I said, they are currently idle, not doing anything.

It seems to me that you've updated evolution-data-server package, but the background processes were not restarted yet (this is not forced in RPM), which might or might not be related. I think so because of the first line in the backtrace:
> warning: core file may not match specified executable file.

I would try to restart the machine, and keep using it for some time. Then we'll see whether you get the crash again.

With respect of a message selection, if you've configured evolution to search for contact photos, then the most of the message selections fires a request to the address books to find the sender.
Comment 12 Louis van Dyk 2014-06-18 12:40:52 EDT
I have updated to F20 so this is no longer a testable issue to me.

Note You need to log in before you can comment on or make changes to this bug.