This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 991571 - Hang in boot
Hang in boot
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
19
Unspecified Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-02 14:36 EDT by David
Modified: 2013-09-18 16:49 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-18 16:49:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages (116.69 KB, text/x-log)
2013-08-02 14:36 EDT, David
no flags Details
cpuinfo and lspci (31.36 KB, text/plain)
2013-08-02 16:35 EDT, Dmitri A. Sergatskov
no flags Details
screenshot of coredump (3.85 MB, image/jpeg)
2013-08-02 16:39 EDT, Dmitri A. Sergatskov
no flags Details
3.7.10-200.1 hang-up errors (4.11 MB, image/jpeg)
2013-08-16 15:59 EDT, Dmitri A. Sergatskov
no flags Details

  None (edit)
Description David 2013-08-02 14:36:06 EDT
Created attachment 782121 [details]
/var/log/messages

Description of problem:
The computer, an ASUS U32A laptop, hangs on black screen on booting with the 3.10.X kernels before the login screen.
The caps lock light is not responding once it is hang.

Version-Release number of selected component (if applicable):
The versions tested are 3.10.3 and 3.10.4 with identical results. It works fine on 3.9.9


Additional info:
There is no login screen, but for the log it seems the Wireless actually connects to my WiFi network.

I am using the LXDE spinoff.

Find /var/log/messages for one of the runs.
Comment 1 Dmitri A. Sergatskov 2013-08-02 16:35:22 EDT
Created attachment 782168 [details]
cpuinfo and lspci
Comment 2 Dmitri A. Sergatskov 2013-08-02 16:39:04 EDT
Created attachment 782179 [details]
screenshot of coredump
Comment 3 Dmitri A. Sergatskov 2013-08-02 16:43:26 EDT
My original comment somehow disappeared:

I have the same problem (computer hangs with 3.10.3-300 and 3.10.4-300
x86-64 kernels)
this is with i7-2600K on intel dz68bc m/b. Screenshot of the coredums and 
output of procinfo and lspci -vvv are attached.

3.9.9.-302 works fine.

Dmitri.
Comment 4 Stanislaw Gruszka 2013-08-06 03:03:15 EDT
I reported bug upstream:
http://marc.info/?l=linux-kernel&m=137577217629761&w=2

On Fedora behalf we probably could make compiling mei as module (CONFIG_INTEL_MEI=m) . Seems it's not needed to have this compiled in kernel and module can be blacklisted, hence allow to workaround the problem.
Comment 5 Josh Boyer 2013-08-06 08:21:50 EDT
(In reply to Stanislaw Gruszka from comment #4)
> I reported bug upstream:
> http://marc.info/?l=linux-kernel&m=137577217629761&w=2
> 
> On Fedora behalf we probably could make compiling mei as module
> (CONFIG_INTEL_MEI=m) . Seems it's not needed to have this compiled in kernel
> and module can be blacklisted, hence allow to workaround the problem.

I did that yesterday.  It was already configured as such.  However, INTEL_MEI_ME used to be an option the MEI driver and hence bool and set to =y.  That was split out to a stand alone module in later versions, but selects INTEL_MEI so both were being built-in.

Anyway, I already changed this to make them both =m.
Comment 6 Stanislaw Gruszka 2013-08-07 08:00:18 EDT
Proposed fix was already posted:
https://lkml.org/lkml/2013/7/17/219

I launched kernel build with above patch, please test when finish to compile:
http://koji.fedoraproject.org/koji/taskinfo?taskID=5789351
Comment 7 Josh Boyer 2013-08-07 08:58:04 EDT
We've been somewhat tracking mei issues in bug 917081
Comment 8 Stanislaw Gruszka 2013-08-09 04:29:40 EDT
David or Dmitri, could you test kernel from comment 6 ?
Comment 9 David 2013-08-09 04:45:26 EDT
I am sorry, I don't know how. If you could point me to the instructions, I would be more than happy to test it.
Comment 10 Stanislaw Gruszka 2013-08-09 04:54:33 EDT
Just download one of the below link (depend if you have 32 bit or 64 bit system)

32 bits:
http://kojipkgs.fedoraproject.org//work/tasks/9354/5789354/kernel-3.10.5-200.bz991571.fc19.i686.rpm

64 bits:
http://kojipkgs.fedoraproject.org//work/tasks/9352/5789352/kernel-3.10.5-200.bz991571.fc19.x86_64.rpm

Then install downloaded rpm as root by:
rpm -ivh 3.10.5-200.bz991571.fc19.*.rpm

Then boot installed kernel and see if it hangs.
Comment 11 Dmitri A. Sergatskov 2013-08-15 19:21:19 EDT
I just tried 3.10.6-200 and it still hangs my computer with a bunch of mei_ messages on the screen. 

Dmitri.
Comment 12 Josh Boyer 2013-08-16 09:41:32 EDT
(In reply to Dmitri A. Sergatskov from comment #11)
> I just tried 3.10.6-200 and it still hangs my computer with a bunch of mei_
> messages on the screen. 
> 
> Dmitri.

That doesn't have the patch Stanislaw added in the scratch kernel.  Of course, now the original build has been garbage collected so we'll need to rebuild it again.  When we do, please try it promptly.
Comment 13 Josh Boyer 2013-08-16 13:20:35 EDT
Here's the scratch build.  Please test when it completes:

http://koji.fedoraproject.org/koji/taskinfo?taskID=5822807
Comment 14 Dmitri A. Sergatskov 2013-08-16 15:53:39 EDT
With 3.7-10-200.1 
I was able to get to the login screen but it locked-up when i was entering my password. If I reboot into runlevel 3, I see the familiar mei_ reset errors.

Dmitri.
Comment 15 Dmitri A. Sergatskov 2013-08-16 15:59:56 EDT
Created attachment 787453 [details]
3.7.10-200.1 hang-up errors

console errors after 3.7.10-200.1 boots up
Comment 16 Stanislaw Gruszka 2013-08-19 07:34:51 EDT
I'll let upstream maintainer know. For now, you should be able to workaround problem by adding line:

blacklist mei

to /etc/modprobe.d/blacklist.conf
Comment 17 Dmitri A. Sergatskov 2013-08-19 07:43:41 EDT
I did add 

blacklist mei

to /etc/modprobe.d/blacklist.conf

but that did not help. 

Perhaps I need to recreate a new bootimage with dracut
(as somebody suggested in one of the related bug reports);
I have not done that.

I do not see any problem staying with 3.9.9-302 for now.
Comment 18 Stanislaw Gruszka 2013-08-19 07:55:43 EDT
(In reply to Dmitri A. Sergatskov from comment #17)
> Perhaps I need to recreate a new bootimage with dracut
That probable. Do your 3.10 kernels have mei.ko module? You can check that by

ls /lib/modules/3.10.*/kernel/drivers/misc/mei/
Comment 19 Dmitri A. Sergatskov 2013-08-19 08:14:43 EDT
find /lib/modules/3.10.* -name "mei*"
/lib/modules/3.10.6-200.fc19.x86_64/kernel/drivers/nfc/mei_phy.ko
/lib/modules/3.10.6-200.fc19.x86_64/kernel/drivers/misc/mei
/lib/modules/3.10.6-200.fc19.x86_64/kernel/drivers/misc/mei/mei-me.ko
/lib/modules/3.10.6-200.fc19.x86_64/kernel/drivers/misc/mei/mei.ko
/lib/modules/3.10.7-200.1.fc19.x86_64/kernel/drivers/nfc/mei_phy.ko
/lib/modules/3.10.7-200.1.fc19.x86_64/kernel/drivers/misc/mei
/lib/modules/3.10.7-200.1.fc19.x86_64/kernel/drivers/misc/mei/mei-me.ko
/lib/modules/3.10.7-200.1.fc19.x86_64/kernel/drivers/misc/mei/mei.ko
Comment 20 Stanislaw Gruszka 2013-08-19 08:28:56 EDT
So yes, initramfs should be recreated, probably with "--omit-drivers mei" dracut option.
Comment 21 Josh Boyer 2013-08-23 17:30:37 EDT
Here's a scratch build with all known mei patches backported.  Please test and let us know if your issue is resolved (without the mei modules blacklisted).

http://koji.fedoraproject.org/koji/taskinfo?taskID=5847415
Comment 22 Dmitri A. Sergatskov 2013-08-23 21:42:17 EDT
So far looks good for me:

[root@das200 ~]# uname -r
3.10.9-200.2.fc19.x86_64
[root@das200 ~]# lsmod | grep mei
mei_me                 18421  0 
mei                    76781  1 mei_me

no errors in /var/log/messages either....

Dmitri.
Comment 23 Josh Boyer 2013-08-26 09:36:13 EDT
OK, one more scratch build to test, this time with just the 4 patches submitted for the 3.10.y stable kernel.  Thanks for testing, we appreciate it:

http://koji.fedoraproject.org/koji/taskinfo?taskID=5854464
Comment 24 Dmitri A. Sergatskov 2013-08-26 18:00:14 EDT
200.3 is similar to 200.1 for me (see comments #14) -- I am able to boot,
but computer hangs soon after with a bunch of mei_ messages...
Comment 25 Tore H. Larsen 2013-09-13 06:58:32 EDT
cc
Comment 26 Tore H. Larsen 2013-09-13 07:02:44 EDT
Seeing the same.  Lenovo W510. 

Hang situation:

Sep 13 12:39:46 bgo-torel kernel: [40976.019926] cfg80211:   (57240000 KHz - 65880000 KHz @ 2160000 KHz), (N/A, 4000 mBm)
Sep 13 12:39:56 bgo-torel kernel: [40985.934471] mei_me 0000:00:16.0: reset: init clients timeout hbm_state = 1.
Sep 13 12:39:56 bgo-torel kernel: [40985.934482] mei_me 0000:00:16.0: unexpected reset: dev_state = RESETTING
Sep 13 12:40:26 bgo-torel kernel: [41015.979781] mei_me 0000:00:16.0: reset: init clients timeout hbm_state = 1.
Sep 13 12:40:26 bgo-torel kernel: [41015.979792] mei_me 0000:00:16.0: unexpected reset: dev_state = RESETTING
Sep 13 12:40:56 bgo-torel kernel: [41046.029004] mei_me 0000:00:16.0: reset: init clients timeout hbm_state = 1.
Sep 13 12:40:56 bgo-torel kernel: [41046.029014] mei_me 0000:00:16.0: unexpected reset: dev_state = RESETTING
Sep 13 12:41:27 bgo-torel kernel: [41076.074171] mei_me 0000:00:16.0: reset: init clients timeout hbm_state = 1.
Sep 13 12:41:27 bgo-torel kernel: [41076.074181] mei_me 0000:00:16.0: unexpected reset: dev_state = RESETTING
Sep 13 12:41:57 bgo-torel kernel: [41106.119336] mei_me 0000:00:16.0: reset: init clients timeout hbm_state = 1.
Sep 13 12:41:57 bgo-torel kernel: [41106.119347] mei_me 0000:00:16.0: unexpected reset: dev_state = RESETTING
Sep 13 12:42:27 bgo-torel kernel: [41136.164533] mei_me 0000:00:16.0: reset: init clients timeout hbm_state = 1.
Sep 13 12:42:27 bgo-torel kernel: [41136.164544] mei_me 0000:00:16.0: unexpected reset: dev_state = RESETTING
Sep 13 12:42:57 bgo-torel kernel: [41166.209852] mei_me 0000:00:16.0: reset: init clients timeout hbm_state = 1.
Sep 13 12:42:57 bgo-torel kernel: [41166.209862] mei_me 0000:00:16.0: unexpected reset: dev_state = RESETTING
Sep 13 12:43:27 bgo-torel kernel: [41196.254972] mei_me 0000:00:16.0: reset: init clients timeout hbm_state = 1.
Sep 13 12:43:27 bgo-torel kernel: [41196.254982] mei_me 0000:00:16.0: unexpected reset: dev_state = RESETTING
Sep 13 12:43:57 bgo-torel kernel: [41226.300251] mei_me 0000:00:16.0: reset: init clients timeout hbm_state = 1.
Sep 13 12:43:57 bgo-torel kernel: [41226.300262] mei_me 0000:00:16.0: unexpected reset: dev_state = RESETTING
^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@^@Sep 13 12:48:14 bgo-torel rsyslogd: [origin software="rsyslogd" swVersion="7.2.6" x-pid="486" x-info="http://www.rsyslog.com"] start

]# modinfo mei_me
filename:       /lib/modules/3.10.9-200.fc19.x86_64/kernel/drivers/misc/mei/mei-me.ko
license:        GPL v2
description:    Intel(R) Management Engine Interface
author:         Intel Corporation
alias:          pci:v00008086d00009C3Asv*sd*bc*sc*i*
alias:          pci:v00008086d00008C3Asv*sd*bc*sc*i*
alias:          pci:v00008086d00001DBAsv*sd*bc*sc*i*
alias:          pci:v00008086d00001CBAsv*sd*bc*sc*i*
alias:          pci:v00008086d00001E3Asv*sd*bc*sc*i*
alias:          pci:v00008086d00001D3Asv*sd*bc*sc*i*
alias:          pci:v00008086d00001C3Asv*sd*bc*sc*i*
alias:          pci:v00008086d00003B65sv*sd*bc*sc*i*
alias:          pci:v00008086d00003B64sv*sd*bc*sc*i*
alias:          pci:v00008086d00002E34sv*sd*bc*sc*i*
alias:          pci:v00008086d00002E24sv*sd*bc*sc*i*
alias:          pci:v00008086d00002E14sv*sd*bc*sc*i*
alias:          pci:v00008086d00002E04sv*sd*bc*sc*i*
alias:          pci:v00008086d00002A74sv*sd*bc*sc*i*
alias:          pci:v00008086d00002A64sv*sd*bc*sc*i*
alias:          pci:v00008086d00002A54sv*sd*bc*sc*i*
alias:          pci:v00008086d00002A44sv*sd*bc*sc*i*
alias:          pci:v00008086d000028F4sv*sd*bc*sc*i*
alias:          pci:v00008086d000028E4sv*sd*bc*sc*i*
alias:          pci:v00008086d000028D4sv*sd*bc*sc*i*
alias:          pci:v00008086d000028C4sv*sd*bc*sc*i*
alias:          pci:v00008086d000028B4sv*sd*bc*sc*i*
alias:          pci:v00008086d000029F4sv*sd*bc*sc*i*
alias:          pci:v00008086d000029E4sv*sd*bc*sc*i*
alias:          pci:v00008086d000029D4sv*sd*bc*sc*i*
alias:          pci:v00008086d000029C4sv*sd*bc*sc*i*
alias:          pci:v00008086d000029B4sv*sd*bc*sc*i*
alias:          pci:v00008086d00002A14sv*sd*bc*sc*i*
alias:          pci:v00008086d00002A04sv*sd*bc*sc*i*
alias:          pci:v00008086d000029A4sv*sd*bc*sc*i*
alias:          pci:v00008086d00002994sv*sd*bc*sc*i*
alias:          pci:v00008086d00002984sv*sd*bc*sc*i*
alias:          pci:v00008086d00002974sv*sd*bc*sc*i*
depends:        mei
intree:         Y
vermagic:       3.10.9-200.fc19.x86_64 SMP mod_unload 
signer:         Fedora kernel signing key
sig_key:        3C:B4:78:D2:91:DF:D1:30:AA:4F:69:CA:01:FE:79:DB:91:F9:42:9B
sig_hashalgo:   sha256

# modinfo  mei
filename:       /lib/modules/3.10.9-200.fc19.x86_64/kernel/drivers/misc/mei/mei.ko
license:        GPL v2
description:    Intel(R) Management Engine Interface
author:         Intel Corporation
depends:        
intree:         Y
vermagic:       3.10.9-200.fc19.x86_64 SMP mod_unload 
signer:         Fedora kernel signing key
sig_key:        3C:B4:78:D2:91:DF:D1:30:AA:4F:69:CA:01:FE:79:DB:91:F9:42:9B
sig_hashalgo:   sha256

# lsmod | grep mei
mei_me                 18609  0 
mei                    76656  1 mei_me
Comment 27 Josh Boyer 2013-09-18 16:43:25 EDT
*********** MASS BUG UPDATE **************

We apologize for the inconvenience.  There is a large number of bugs to go through and several of them have gone stale.  Due to this, we are doing a mass bug update across all of the Fedora 19 kernel bugs.

Fedora 19 has now been rebased to 3.11.1-200.fc19.  Please test this kernel update and let us know if you issue has been resolved or if it is still present with the newer kernel.

If you experience different issues, please open a new bug report for those.
Comment 28 Tore H. Larsen 2013-09-18 16:48:22 EDT
Seems to be fixed for me with 3.10.11-200.fc19.x86_64
Comment 29 Josh Boyer 2013-09-18 16:49:22 EDT
Thank you for letting us know.

Note You need to log in before you can comment on or make changes to this bug.