Bug 991622 - fd leaks observed while running dbench with "open-behind" volume option set to "on" on a replicate volume
fd leaks observed while running dbench with "open-behind" volume option set t...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: unclassified (Show other bugs)
mainline
Unspecified Unspecified
high Severity unspecified
: ---
: ---
Assigned To: Pranith Kumar K
:
: 996324 (view as bug list)
Depends On: 990510
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-02 23:07 EDT by Pranith Kumar K
Modified: 2014-04-17 07:45 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.5.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 990510
Environment:
Last Closed: 2014-04-17 07:45:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Anand Avati 2013-08-02 23:37:07 EDT
REVIEW: http://review.gluster.org/5493 (performance/open-behind: Fix fd-leaks in unlink, rename) posted (#1) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 2 Anand Avati 2013-08-02 23:42:46 EDT
REVIEW: http://review.gluster.org/5493 (performance/open-behind: Fix fd-leaks in unlink, rename) posted (#2) for review on master by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 3 Anand Avati 2013-08-03 08:38:22 EDT
COMMIT: http://review.gluster.org/5493 committed in master by Anand Avati (avati@redhat.com) 
------
commit 8c1304b03542eefbbff82014827fc782c3c3584f
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Sat Aug 3 08:27:27 2013 +0530

    performance/open-behind: Fix fd-leaks in unlink, rename
    
    Change-Id: Ia8d4bed7ccd316a83c397b53b9c1b1806024f83e
    BUG: 991622
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/5493
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
Comment 4 Anand Avati 2013-09-05 06:38:56 EDT
REVIEW: http://review.gluster.org/5810 (performance/open-behind: Fix fd-leaks in unlink, rename) posted (#1) for review on release-3.4 by Vijay Bellur (vbellur@redhat.com)
Comment 5 Anand Avati 2013-09-05 11:13:40 EDT
REVIEW: http://review.gluster.org/5810 (performance/open-behind: Fix fd-leaks in unlink, rename) posted (#2) for review on release-3.4 by Vijay Bellur (vbellur@redhat.com)
Comment 6 Anand Avati 2013-09-06 00:27:44 EDT
REVIEW: http://review.gluster.org/5810 (performance/open-behind: Fix fd-leaks in unlink, rename) posted (#3) for review on release-3.4 by Vijay Bellur (vbellur@redhat.com)
Comment 7 Anand Avati 2013-09-06 03:43:39 EDT
REVIEW: http://review.gluster.org/5810 (performance/open-behind: Fix fd-leaks in unlink, rename) posted (#4) for review on release-3.4 by Vijay Bellur (vbellur@redhat.com)
Comment 8 Anand Avati 2013-09-07 11:01:58 EDT
REVIEW: http://review.gluster.org/5810 (performance/open-behind: Fix fd-leaks in unlink, rename) posted (#5) for review on release-3.4 by Vijay Bellur (vbellur@redhat.com)
Comment 9 Lukas Bezdicka 2013-09-09 04:08:40 EDT
*** Bug 996324 has been marked as a duplicate of this bug. ***
Comment 10 Anand Avati 2013-09-09 20:22:47 EDT
COMMIT: http://review.gluster.org/5810 committed in release-3.4 by Anand Avati (avati@redhat.com) 
------
commit 63d18642d9829a9932781fc628b0e40a2bc545ab
Author: Pranith Kumar K <pkarampu@redhat.com>
Date:   Sat Aug 3 08:27:27 2013 +0530

    performance/open-behind: Fix fd-leaks in unlink, rename
    
    Change-Id: Ia8d4bed7ccd316a83c397b53b9c1b1806024f83e
    BUG: 991622
    Signed-off-by: Pranith Kumar K <pkarampu@redhat.com>
    Reviewed-on: http://review.gluster.org/5493
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>
    Reviewed-on: http://review.gluster.org/5810
    Reviewed-by: Kaleb KEITHLEY <kkeithle@redhat.com>
Comment 11 Niels de Vos 2014-04-17 07:45:11 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.5.0, please reopen this bug report.

glusterfs-3.5.0 has been announced on the Gluster Developers mailinglist [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://thread.gmane.org/gmane.comp.file-systems.gluster.devel/6137
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.