Bug 991650 - Getting [nm-vpn-connection.c:1374] get_secrets_cb(): Failed to request VPN secrets #2: (6) No agents were available for this request.
Getting [nm-vpn-connection.c:1374] get_secrets_cb(): Failed to request VPN se...
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: NetworkManager-vpnc (Show other bugs)
19
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-03 05:56 EDT by enrico
Modified: 2015-02-17 11:32 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 11:32:28 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description enrico 2013-08-03 05:56:54 EDT
Description of problem:
VPNC vpn connections cannot be established via NetworkManager.

You can read this on /var/log/messages:

Aug  3 11:47:19 tweety NetworkManager[517]: <info> Starting VPN service 'vpnc'...
Aug  3 11:47:19 tweety NetworkManager[517]: <info> VPN service 'vpnc' started (org.freedesktop.NetworkManager.vpnc), PID 6729
Aug  3 11:47:19 tweety NetworkManager[517]: <info> VPN service 'vpnc' appeared; activating connections
Aug  3 11:47:19 tweety NetworkManager[517]: <error> [1375523239.643325] [nm-vpn-connection.c:1374] get_secrets_cb(): Failed to request VPN secrets #2: (6) No agents were available for this request.
Aug  3 11:47:19 tweety NetworkManager[517]: <info> Policy set 'wargames' (wlp2s0) as default for IPv4 routing and DNS.
Aug  3 11:47:19 tweety /etc/gdm/Xsession[1232]: Window manager warning: Log level 16: async_got_type: could not read properties for /org/freedesktop/NetworkManager/ActiveConnection/9: Method "Get" with signature "ss" on interface "org.freedesktop.DBus.Properties" doesn't exist
Aug  3 11:47:19 tweety /etc/gdm/Xsession[1232]: Window manager warning: Log level 16: Device activation failed: (1) Creating object for path '/org/freedesktop/NetworkManager/ActiveConnection/9' failed in libnm-glib.
Aug  3 11:47:24 tweety NetworkManager[517]: <info> VPN service 'vpnc' disappeared

Setting up VPNC connection via command line works.

Version-Release number of selected component (if applicable):
NetworkManager-vpnc-0.9.8.2-2.fc19.x86_64
vpnc-script-0.5.3-17.svn457.fc19.noarch
vpnc-0.5.3-17.svn457.fc19.x86_64
NetworkManager-vpnc-gnome-0.9.8.2-2.fc19.x86_64


How reproducible:
Define a vpnc connection in the NetworkManager user interface. In my case I'm using no cerificates, just type in gateway, group, group password, username and user password.
Try to connect, see it fail.

Steps to Reproduce:
1. Define a vpnc connection in the NetworkManager user interface. In my case I'm using no cerificates, just type in gateway, group, group password, username and user password.

2. Save the connection definition.

3. tail -f /var/log/messages

4. click on the nwely defined vpn

5. see it fail

Actual results:
No VPN connection is started

Expected results:
VPN connection starting

Additional info:
Worked fine in f18.
Comment 1 enrico 2013-08-03 06:08:16 EDT
Note: I'm using Cinnamon desktop cinnamon-1.9.1-19.fc19.x86_64. Works fine with gnome gnome-desktop3-3.8.2-2.fc19.x86_64.
Comment 2 prohol 2013-08-22 04:43:42 EDT
I have the same as Enrico - F19 x64 and cinnamon-1.9.1-19.fc19.x86_64. On gnome shell works fine.
Comment 3 Yulia Kopkova 2013-08-22 09:14:54 EDT
Same here with openconnect. Let me know if need more info.
Comment 4 Carlos "casep" Sepulveda 2013-12-05 13:30:42 EST
Hi:
I've the same issue on Fedora 20 x86  (working OK on Gnome, not working on Cinnamon)

cinnamon-2.0.14-3.fc20.i686
NetworkManager-openconnect-0.9.8.0-2.fc20.i686
NetworkManager-0.9.9.0-20.git20131003.fc20.i686
gnome-desktop3-3.10.2-2.fc20.i686
Comment 5 Jacek Pliszka 2013-12-08 16:38:49 EST
Same issue on Fedora 20 updated on 2013-12-08 22:14 CEST, openvpn and PTPT VPN do not work for me - both need 'ask always'


<info> Starting VPN service 'openvpn'...
<info> VPN service 'openvpn' started (org.freedesktop.NetworkManager.openvpn), PID 27022
<info> VPN service 'openvpn' appeared; activating connections
(gnome-shell:1647): Gjs-WARNING **: JS ERROR: error while reading VPN plugin output keyfile: GLib.KeyFileError: Key file does not have

VPNRequestHandler<._showNewStyleDialog@/usr/share/gnome-shell/js/ui/components/networkAgent.js:516
wrapper@/usr/share/gjs-1.0/lang.js:213
VPNRequestHandler<._readStdoutNewStyle/<@/usr/share/gnome-shell/js/ui/components/networkAgent.js:495
<error> [1386538563.779347] [vpn-manager/nm-vpn-connection.c:1538] get_secrets_cb(): Failed to request VPN secrets #3: (6) No agents were available for this request.

(process:27029): GLib-CRITICAL **: g_slice_set_config: assertion 'sys_page_size == 0' failed
(firefox:27029): Gtk-WARNING **: Locale not supported by C library.
Using the fallback 'C' locale.
<info> VPN service 'openvpn' disappeared
Comment 6 Jacek Pliszka 2014-01-07 15:59:26 EST
The error dissappeared for some time but it came back during last week.

Effect: again I can not use any VPN.

This is pretty serious problem for me.
Comment 7 Jacek Pliszka 2014-01-08 10:51:53 EST
OK, the problem dissappeared for VPNs that have fixed password after changing password from Always Ask to Saved

I tried debugging and what I got is when set to Always Ask (a must for one-time-passwords). gnome-session tries to run in script:
/usr/share/gnome-shell/js/ui/components/networkAgent.js

the line below:

/usr/libexec/nm-vpnc-auth-dialog,-u,4b8587bd-f65f-4462-a780-8deda4f7670c,-n,VPNZ,-s,org.freedesktop.NetworkManager.vpnc,--external-ui-mode,-i

but the process just hangs, no window appears, nothing is happening and VPN applet quits.
Comment 8 Jacek Pliszka 2014-01-26 07:15:13 EST
I got an ugly work around in my case.

In /usr/share/gnome-shell/js/ui/components/networkAgent.js

in:

    _showNewStyleDialog: function() {

I replaced:

let data = this._dataStdout.peek_buffer();  //this was returning empty string

by:

let data = "[VPN Plugin UI]\n\
Version=2\n\
Description=You need to authenticate to access the Virtual Private Network 'ospra0'.\n\
Title=Authenticate VPN\n\
[password]\n\
Value=\n\
Label=Password:\n\
IsSecret=true\n\
ShouldAsk=true\n";

And now it works for me but this is so ugly hack...
Comment 9 Yulia Kopkova 2014-03-20 14:57:42 EDT
Still an issue in NetworkManager-vpnc-0.9.8.2-2.fc20.x86_64

Jacek, thanks for fix. This one works.
Comment 10 Jacek Pliszka 2014-03-20 17:27:40 EDT
Yulia - this is not a fix - this is a terribly ugly hack.
And it might get overwritten after update.

Please someone fix it properly - I've been using  RH/Fedora for 18 years and F20 is one of the worst, most buggy releases ever.
Comment 11 Tim Waugh 2014-04-04 04:34:19 EDT
I just saw this on Fedora 20 with GNOME.

Since boot, I had logged in, then later logged out, logged in again, suspended, and this morning I resumed the system and that's when I noticed the problem.

I spotted that there was a 2nd 'gnome-shell' process busy-looping -- not the one from my current session -- and killed it (sorry, didn't look to see what it was doing). At that point I saw:

Apr 04 09:27:16 rubik polkitd[11872]: Unregistered Authentication Agent for unix-session:1 (system bus name :1.80, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale en_GB.utf8) (disconnected from bus)

The VPN password dialog still wouldn't work of course: I had to use Alt-F2 and 'r' to reload the shell in order for it to re-register as an authentication agent.

Once I'd done this, it worked fine again.

I have a feeling this might be the same symptom but a different cause.
Comment 12 Dan Williams 2014-04-04 13:47:03 EDT
Tim: for your issue, if a previous gnome-shell had registered as a password agent, then it would prevent any other gnome-shell with the same unix UID from registering.  So that hung gnome-shell could certainly block password requests from happening until it had quit.  The second, working gnome-shell couldn't register, because the other gnome-shell was blocking it from doing so, and then when the other gnome-shell quit, nothing signals the working gnome-shell to re-register.  That could be worked around by some additions to NetworkManager to notify agents that they can attempt to re-register when another agent quits.

I've filed https://bugzilla.gnome.org/show_bug.cgi?id=727621 upstream for this issue.

---

Everyone: I think I see an issue with the NM-vpnc plugin here, which could be duplicated in the other plugins.

But that issue would only appear if *both* user and group passwords were saved.  It could not appear if either password was set to "always ask".  Which seems to be the opposite of what Jacek experienced.

Can I just re-confirm that this problem only appears when one password is set to Always Ask?
Comment 13 Jacek Pliszka 2014-04-04 15:36:33 EDT
for me NM-vpnc works for me with both passwords saved.

So we have two different problems.

For me NM-openvpn and NM-PPTP plugins do not work with always ask.

Shall I make a separate bug for it ?
Comment 14 Fedora End Of Life 2015-01-09 14:15:14 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 15 Fedora End Of Life 2015-02-17 11:32:28 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.