Bug 991710 - Fedup installs gdm on systems that don't already use it.
Fedup installs gdm on systems that don't already use it.
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fedup (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Will Woods
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-03 17:46 EDT by Joe Zeff
Modified: 2013-08-05 03:03 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-05 02:19:47 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fedup.log from my desktop (1012.72 KB, text/x-log)
2013-08-03 17:46 EDT, Joe Zeff
no flags Details
The fedup.log from my laptop. (1.43 MB, text/x-log)
2013-08-03 17:49 EDT, Joe Zeff
no flags Details

  None (edit)
Description Joe Zeff 2013-08-03 17:46:29 EDT
Created attachment 782397 [details]
fedup.log from my desktop

Description of problem:
I have two computers, a desktop and a laptop.  Both use Xfce with lightdm.  When I used fedup to go from F17 to F19, it installed gdm and a bunch of Gnome cruft without telling me.

Version-Release number of selected component (if applicable):
0.7.3

How reproducible:
100%

Steps to Reproduce:
1. Use fedup on a system with F 17 and gdm not installed
2. Upgrade system
3. Check to see if gdm is installed.

Actual results:
You find that gdm is installed.

Expected results:
You find that gdm is not installed.

Additional info:
On my desktop, it even changed my login manager to gdm, although it didn't on my laptop.  I am including two attachments: fedup.log from my desktop, and laptop-fedup.log from the laptop so that you can see that fedup installed gdm on both systems.
Comment 1 Joe Zeff 2013-08-03 17:49:16 EDT
Created attachment 782398 [details]
The fedup.log from my laptop.
Comment 2 leigh scott 2013-08-05 02:19:47 EDT
This isn't a bug, you  had gnome-classic-session installed


[   420.322] (DD) fedup.depsolve:pkgAdded() added gnome-classic-session.noarch for o
[   420.322] (DD) fedup.depsolve:pkgAdded() obsolete gnome-classic-session.noarch
[   420.333] (DD) fedup.depsolve:procReqPo() req po:   gnome-shell-extension-window-list = 3.8.3-2.fc19 → gnome-classic-session-3.8.3-2.fc19.noarch
[   420.340] (DD) fedup.depsolve:procReqPo() req po:   gnome-shell-extension-places-menu = 3.8.3-2.fc19 → gnome-classic-session-3.8.3-2.fc19.noarch
[   420.344] (DD) fedup.depsolve:procReqPo() req po:   gnome-shell-extension-launch-new-instance = 3.8.3-2.fc19 → gnome-classic-session-3.8.3-2.fc19.noarch
[   420.349] (DD) fedup.depsolve:procReqPo() req po:   gnome-shell-extension-apps-menu = 3.8.3-2.fc19 → gnome-classic-session-3.8.3-2.fc19.noarch
[   420.353] (DD) fedup.depsolve:procReqPo() req po:   gnome-shell-extension-alternate-tab = 3.8.3-2.fc19 → gnome-classic-session-3.8.3-2.fc19.noarch


It was obsoleted for gnome-shell-extensions which require gnome-shell, and g-s requires gdm-libs

$ repoquery --requires gnome-shell
/bin/sh
/usr/bin/python
accountsservice-libs(x86-64)
at-spi2-atk(x86-64)
caribou(x86-64) >= 0.4.8
clutter(x86-64) >= 1.13.4
gdm-libs(x86-64)
gjs(x86-64) >= 1.35.4
gnome-bluetooth(x86-64) >= 1:3.1.0
gnome-desktop3(x86-64) >= 3.7.90
gnome-menus(x86-64) >= 3.5.3
gnome-session-xsession
gobject-introspection(x86-64) >= 0.10.1
gsettings-desktop-schemas(x86-64) >= 3.9.2


And gdm-libs requires gdm


$ repoquery --requires gdm-libs
gdm = 1:3.8.3-2.fc20
Comment 3 Joe Zeff 2013-08-05 02:29:00 EDT
No, I didn't.  I'd been very careful not to install that type of thing on either of my computers.  Also, why did my desktop change from using lightdm to gdm (but not my laptop) if it's not a bug?
Comment 4 leigh scott 2013-08-05 02:45:33 EDT
(In reply to Joe Zeff from comment #3)
> No, I didn't.  

So your log files are lying ?

[   420.322] (DD) fedup.depsolve:pkgAdded() added gnome-classic-session.noarch for o
  
and


[   264.537] (DD) fedup.depsolve:pkgAdded() obsolete gnome-chess.i686
[   264.555] (DD) fedup.depsolve:pkgAdded() added gnome-classic-session.noarch for o
[   264.555] (DD) fedup.depsolve:pkgAdded() obsolete gnome-classic-session.noarch

gnome-classic-session is clearly installed and marked to obsoleted

>  Also, why did my desktop change from using lightdm
> to gdm (but not my laptop) if it's not a bug?

That shouldn't happen, try filing a bug against gdm
Comment 5 Joe Zeff 2013-08-05 03:03:22 EDT
I have no idea how that stuff got in there, if it was there at all.  I know very well that I'd removed gdm from both machines under F17.  And, although it's not part of this report, fedup completely removed wine from both boxes and the package of printer drivers on my desktop.  (I used wine on both machines before the upgrade, and my printer worked.  After the "upgrade," I had to reinstall wine on both of them and my printer didn't work until I reinstalled the drivers.)


And, how should I phrase the bug against gdm?  "Gdm took over from lightdm when fedup installed it during an upgrade?"  Fat chance; they'll just point the finger back at you.

Note You need to log in before you can comment on or make changes to this bug.