Bug 991794 - Make goa_provider_get_for_provider_type robust against NULL
Make goa_provider_get_for_provider_type robust against NULL
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: gnome-online-accounts (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
abrt_hash:9e0a98bd397f224d772ba7fe32a...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-04 07:16 EDT by Łukasz Mierzwa
Modified: 2014-04-10 09:51 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-04-10 09:51:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (79.00 KB, text/plain)
2013-08-04 07:16 EDT, Łukasz Mierzwa
no flags Details
File: cgroup (140 bytes, text/plain)
2013-08-04 07:16 EDT, Łukasz Mierzwa
no flags Details
File: core_backtrace (1.49 KB, text/plain)
2013-08-04 07:16 EDT, Łukasz Mierzwa
no flags Details
File: dso_list (11.94 KB, text/plain)
2013-08-04 07:16 EDT, Łukasz Mierzwa
no flags Details
File: environ (965 bytes, text/plain)
2013-08-04 07:16 EDT, Łukasz Mierzwa
no flags Details
File: limits (1.29 KB, text/plain)
2013-08-04 07:16 EDT, Łukasz Mierzwa
no flags Details
File: maps (58.60 KB, text/plain)
2013-08-04 07:16 EDT, Łukasz Mierzwa
no flags Details
File: open_fds (1.05 KB, text/plain)
2013-08-04 07:16 EDT, Łukasz Mierzwa
no flags Details
File: proc_pid_status (927 bytes, text/plain)
2013-08-04 07:16 EDT, Łukasz Mierzwa
no flags Details
File: var_log_messages (690 bytes, text/plain)
2013-08-04 07:16 EDT, Łukasz Mierzwa
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 727965 None None None Never

  None (edit)
Description Łukasz Mierzwa 2013-08-04 07:16:25 EDT
Description of problem:
This might be related to me trying to setup google account with 2 factor auth, it failed with constant "Expired credentials"

Version-Release number of selected component:
gnome-online-accounts-3.8.2-1.fc19

Additional info:
reporter:       libreport-2.1.5
backtrace_rating: 4
cmdline:        /usr/libexec/goa-daemon
crash_function: strcmp
executable:     /usr/libexec/goa-daemon
kernel:         3.10.4-300.fc19.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
Thread no. 1 (7 frames)
 #0 strcmp at ../sysdeps/x86_64/strcmp.S:213
 #1 g_io_extension_point_get_extension_by_name at giomodule.c:1248
 #2 goa_provider_get_for_provider_type at goaprovider.c:718
 #3 update_account_object at goadaemon.c:476
 #4 process_config_entries at goadaemon.c:607
 #5 goa_daemon_reload_configuration at goadaemon.c:696
 #6 on_config_file_monitor_timeout at goadaemon.c:161

Potential duplicate: bug 830164
Comment 1 Łukasz Mierzwa 2013-08-04 07:16:29 EDT
Created attachment 782476 [details]
File: backtrace
Comment 2 Łukasz Mierzwa 2013-08-04 07:16:32 EDT
Created attachment 782477 [details]
File: cgroup
Comment 3 Łukasz Mierzwa 2013-08-04 07:16:35 EDT
Created attachment 782478 [details]
File: core_backtrace
Comment 4 Łukasz Mierzwa 2013-08-04 07:16:39 EDT
Created attachment 782479 [details]
File: dso_list
Comment 5 Łukasz Mierzwa 2013-08-04 07:16:41 EDT
Created attachment 782480 [details]
File: environ
Comment 6 Łukasz Mierzwa 2013-08-04 07:16:44 EDT
Created attachment 782481 [details]
File: limits
Comment 7 Łukasz Mierzwa 2013-08-04 07:16:47 EDT
Created attachment 782482 [details]
File: maps
Comment 8 Łukasz Mierzwa 2013-08-04 07:16:50 EDT
Created attachment 782483 [details]
File: open_fds
Comment 9 Łukasz Mierzwa 2013-08-04 07:16:53 EDT
Created attachment 782484 [details]
File: proc_pid_status
Comment 10 Łukasz Mierzwa 2013-08-04 07:16:56 EDT
Created attachment 782485 [details]
File: var_log_messages
Comment 11 Debarshi Ray 2014-04-10 09:38:19 EDT
Looks like you had a corrupt accounts.conf.
Comment 12 Debarshi Ray 2014-04-10 09:51:02 EDT
This is fixed in newer versions of gnome-online-accounts >= 3.10.0

Note You need to log in before you can comment on or make changes to this bug.