Bug 991806 - Regression in F19: Flashing and artifacts with nvidia
Regression in F19: Flashing and artifacts with nvidia
Status: CLOSED EOL
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-nouveau (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ben Skeggs
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-04 10:34 EDT by amturnip
Modified: 2015-02-17 11:33 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-02-17 11:33:51 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
full dmesg containing a lot of nouveau and kernel traces (108.55 KB, text/x-log)
2013-11-04 10:22 EST, Pierre Conti
no flags Details

  None (edit)
Description amturnip 2013-08-04 10:34:47 EDT
Description of problem:  F19's Gnome desktop flashes rectangular areas while redrawing, sometimes misses the text of a button, and occasionally freezes in the midst of the initial animation that replaces the login background with my account's background.


Version-Release number of selected component (if applicable):

Fedora 19 (only; Fedora 18 was fine, current through yesterday, 2013-08-03)

$ lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation G72 [GeForce 7300 LE] (rev a1)

$ rpm -q kernel xorg-x11-drv-nouveau
kernel-3.9.5-301.fc19.x86_64
kernel-3.10.4-300.fc19.x86_64
xorg-x11-drv-nouveau-1.0.7-1.fc19.x86_64

(Both of the listed kernel versions exhibit the problems.)


How reproducible:

Animation artifacts are consistent.



Steps to Reproduce:

A) 

1.Punch the mouse to the upper left to put Gnome into its mode.
2.As Gnome draws waves around the pointer, a rectangular area, with an extent that first increases and then decreases in concert with the waves', flashes alternately with the waves.  In my installed system the flash is light gray.  When I boot the live image it is a neon wash with green at lower left and red at upper right.
3.Move the mouse *slowly* down the column of activities.
4.As the mouse passes each activity, a rectangular region flashes, covering the activity you are departing and the activity you are entering and their respective labels off to the right.
5.Move the mouse *quickly* up the column of activities.
6.The flash background (icon area only, not labels - move fast and you don't get labels?) sticks around until you pause the mouse and then the screen repaints the proper color.

B)

1.Open a couple of windows, such as Firefox and gedit.
2.Punch the mouse to the upper left to put Gnome into its mode.
3.Move the mouse onto the representation of an open window.
4.Suddenly the representation's non-desktop-background area expands to circumscribe an additional border that includes a round X at its upper right.  The round X is not a tidy bulbous excrescence as in F18, but rather it is a round element within a newly-expanded rectangular area that also captures the entire representation of the open window.

C)

1.Select "Power Off"
2.Dialog appears - power off, restart, or cancel?
3.Move mouse along the buttons, first power-off, then restart.
4.Button text disappears as mouse enters - replaced by gray rectangular area.
5.Button text might reappear as (but not until) the mouse moves again.


Actual results:

Flashing areas make Gnome a distraction.


Expected results:

F19 should look like F18:  smooth and unobtrusive, no flashing


Additional info:

F18 worked very, very well on this same hardware yesterday.  It was using nouveau - it gave the smooth, more-or-less fluid graphical environment right from booting through to the desktop. 

Attempting to work around the problem, I installed an nvidia-304xx driver from elsewhere.  It did not suffer the indignities above.  (But it brought its own indignities.)

Gnome's system Settings says, "Graphics: Gallium 0.4 on NV46"
Comment 1 Domenico Ferrari 2013-08-08 06:08:38 EDT
I'm using XFCE desktop. I see artifacts in the firefox tab bar only.

$ lspci |grep VGA
02:00.0 VGA compatible controller: NVIDIA Corporation NV44 [GeForce 7100 GS] (rev a1)

kernel-3.9.9-302.fc19.i686
kernel-3.10.3-300.fc19.i686
kernel-3.10.4-300.fc19.i686
xorg-x11-drv-nouveau-1.0.9-1.fc19.i686
Comment 2 Ron Yorston 2013-08-11 12:27:37 EDT
My experience is similar to that of the original reporter.  Hardware that worked fine in F18 is showing graphical corruption and freezing in F19.

$  lspci |grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation NV44A [GeForce 6200] (rev a1)

Specifically, I am seeing grey rectangles replacing buttons, as in C above, and the login name and icon in gdm vanish when I type the first character of my password only to reappear on the second.

The most irritating issue, though, is the occasional freeze in the startup animation.  When this happens gnome-shell is using 100% of the CPU.  Attaching to the process using gdb shows this stack traceback:

#0  0xb7724424 in __kernel_vsyscall ()
#1  0xb58ea26c in sched_yield () from /lib/libc.so.6
#2  0xb38ccd7a in nouveau_fence_wait () from /usr/lib/dri/nouveau_dri.so
#3  0xb38cc49c in nouveau_screen_fence_finish ()
   from /usr/lib/dri/nouveau_dri.so
#4  0xb35fa4e1 in st_finish () from /usr/lib/dri/nouveau_dri.so
#5  0xb35fa523 in st_glFinish () from /usr/lib/dri/nouveau_dri.so
#6  0xb3504976 in _mesa_finish () from /usr/lib/dri/nouveau_dri.so
#7  0xb3505520 in _mesa_Finish () from /usr/lib/dri/nouveau_dri.so
#8  0xb4cf6c5f in shared_dispatch_stub_216 () from /lib/libglapi.so.0
#9  0xb682ea03 in _cogl_winsys_onscreen_swap_region () from /lib/libcogl.so.12
#10 0xb6823237 in cogl_onscreen_swap_region () from /lib/libcogl.so.12
#11 0xb68d95d0 in clutter_stage_cogl_redraw () from /lib/libclutter-1.0.so.0
#12 0xb694c510 in _clutter_stage_window_redraw () from /lib/libclutter-1.0.so.0
#13 0xb694868b in _clutter_stage_do_update () from /lib/libclutter-1.0.so.0
#14 0xb692bb4a in clutter_clock_dispatch () from /lib/libclutter-1.0.so.0
#15 0xb5a160f6 in g_main_context_dispatch () from /lib/libglib-2.0.so.0
#16 0xb5a164a8 in g_main_context_iterate.isra.21 () from /lib/libglib-2.0.so.0
#17 0xb5a16923 in g_main_loop_run () from /lib/libglib-2.0.so.0
#18 0xb75bfb9c in meta_run () from /lib/libmutter.so.0
#19 0x0804990d in main ()
Comment 3 Keith Bare 2013-08-17 11:55:59 EDT
I'm using the Gnome desktop and have experienced similar problems with rectangles in gnome shell.  The 3.9 kernels work, 3.10 kernels start having problems shortly after login (tested every 3.10 kernel released thus far)

$ lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 620] (rev a1)

kernel-3.9.9-302.fc19.x86_64
kernel-3.10.5-201.fc19.x86_64
kernel-3.10.6-200.fc19.x86_64
xorg-x11-drv-nouveau-1.0.9-1.fc19.x86_64
Comment 4 leverno 2013-11-03 10:03:22 EST
I'm experiencing the same issue on Gnome desktop. 
I'm a first time fedora user and cannot comment on previous workings.

lspci |grep VGA
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)


rpm -q kernel xorg-x11-drv-nouveau
kernel-3.9.5-301.fc19.x86_64
xorg-x11-drv-nouveau-1.0.7-1.fc19.x86_64
Comment 5 Pierre Conti 2013-11-04 10:19:42 EST
Same problems (screen/system freeze, artefacs, ...)  for me after upgrade from F18 to F19 some information here below:
=======================================================
#> lspci | grep VGA
01:00.0 VGA compatible controller: NVIDIA Corporation G72 [GeForce 7300 LE] (rev a1)
=======================================================
#> lsmod
Module                  Size  Used by
fuse                   76063  1 
nf_conntrack_netbios_ns    12585  0 
nf_conntrack_broadcast    12487  1 nf_conntrack_netbios_ns
ipt_MASQUERADE         12760  1 
ip6t_REJECT            12826  2 
xt_conntrack           12664  42 
bnep                   18959  2 
bluetooth             317776  7 bnep
rfkill                 20721  2 bluetooth
ebtable_nat            12695  0 
ebtable_broute         12635  0 
bridge                 90494  1 ebtable_broute
stp                    12756  1 bridge
llc                    13733  2 stp,bridge
ebtable_filter         12715  0 
ebtables               21315  3 ebtable_broute,ebtable_nat,ebtable_filter
ip6table_nat           12871  1 
nf_conntrack_ipv6      18318  24 
nf_defrag_ipv6         26016  1 nf_conntrack_ipv6
nf_nat_ipv6            13053  1 ip6table_nat
ip6table_mangle        12620  1 
ip6table_security      12630  1 
ip6table_raw           12603  1 
ip6table_filter        12711  1 
ip6_tables             17634  5 ip6table_filter,ip6table_mangle,ip6table_security,ip6table_nat,ip6table_raw
iptable_nat            12867  1 
nf_conntrack_ipv4      14320  20 
nf_defrag_ipv4         12601  1 nf_conntrack_ipv4
nf_nat_ipv4            13039  1 iptable_nat
nf_nat                 24756  5 ipt_MASQUERADE,nf_nat_ipv4,nf_nat_ipv6,ip6table_nat,iptable_nat
nf_conntrack           74019  11 nf_conntrack_netbios_ns,ipt_MASQUERADE,nf_nat,nf_nat_ipv4,nf_nat_ipv6,xt_conntrack,ip6table_nat,nf_conntrack_broadcast,iptable_nat,nf_conntrack_ipv4,nf_conntrack_ipv6
iptable_mangle         12615  1 
iptable_security       12625  1 
iptable_raw            12598  1 
snd_hda_codec_realtek    45592  1 
snd_hda_intel          42658  4 
snd_usb_audio         119185  2 
snd_hda_codec         155748  2 snd_hda_codec_realtek,snd_hda_intel
snd_usbmidi_lib        24133  1 snd_usb_audio
snd_rawmidi            24472  1 snd_usbmidi_lib
snd_hwdep              13232  2 snd_usb_audio,snd_hda_codec
snd_seq                54679  0 
snd_seq_device         13824  2 snd_seq,snd_rawmidi
iTCO_wdt               13256  0 
iTCO_vendor_support    13243  1 iTCO_wdt
snd_pcm                81999  3 snd_usb_audio,snd_hda_codec,snd_hda_intel
tuner_simple           17839  1 
tuner_types            19197  1 tuner_simple
wm8775                 12906  1 
tda9887                17625  1 
gpio_ich               13236  0 
tda8290                21979  0 
ppdev                  17363  0 
tuner                  26740  2 
cx25840                52501  1 
snd_page_alloc         13852  2 snd_pcm,snd_hda_intel
coretemp               13195  0 
snd_timer              23750  2 snd_pcm,snd_seq
kvm_intel             128105  0 
kvm                   359244  1 kvm_intel
ivtv                  142292  0 
tveeprom               16892  1 ivtv
cx2341x                27141  1 ivtv
v4l2_common            14661  5 ivtv,cx2341x,cx25840,tuner,wm8775
videodev              107792  6 ivtv,cx2341x,cx25840,tuner,v4l2_common,wm8775
serio_raw              13189  0 
lpc_ich                16864  0 
media                  19980  1 videodev
i2c_i801               17783  0 
snd                    59132  23 snd_hda_codec_realtek,snd_usb_audio,snd_hwdep,snd_timer,snd_pcm,snd_seq,snd_rawmidi,snd_usbmidi_lib,snd_hda_codec,snd_hda_intel,snd_seq_device
soundcore              14123  1 snd
microcode              18789  0 
of_i2c                 12907  1 i2c_i801
r8169                  61562  0 
mii                    13311  1 r8169
parport_pc             27416  0 
parport                39185  2 ppdev,parport_pc
acpi_cpufreq           19118  0 
mperf                  12551  1 acpi_cpufreq
uinput                 17265  0 
nouveau               834949  3 
mxm_wmi                12761  1 nouveau
wmi                    18273  2 mxm_wmi,nouveau
video                  18595  1 nouveau
i2c_algo_bit           13065  2 ivtv,nouveau
drm_kms_helper         44716  1 nouveau
ata_generic            12790  0 
ttm                    58677  1 nouveau
pata_acpi              12886  0 
drm                   230162  5 ttm,drm_kms_helper,nouveau
pata_jmicron           12662  0 
i2c_core               28619  16 drm,ivtv,i2c_i801,cx25840,tuner,drm_kms_helper,tda8290,tda9887,i2c_algo_bit,of_i2c,v4l2_common,tveeprom,nouveau,tuner_simple,wm8775,videodev
=========================================================
#> rpm -qa | grep x11
libX11-1.6.0-1.fc19.i686
xorg-x11-server-common-1.14.3-2.fc19.i686
xorg-x11-xinit-1.3.2-8.fc19.i686
xorg-x11-xauth-1.0.7-3.fc19.i686
xorg-x11-drv-synaptics-1.7.1-4.fc19.i686
xorg-x11-drv-wacom-0.22.0-2.fc19.i686
xorg-x11-drv-vesa-2.3.2-9.fc19.i686
qt-x11-4.8.5-10.fc19.i686
xorg-x11-drv-intel-2.21.12-2.fc19.i686
xorg-x11-drv-modesetting-0.6.0-7.fc19.i686
xorg-x11-drv-mga-1.6.2-7.fc19.i686
xorg-x11-drv-ati-7.1.0-5.20130408git6e74aacc5.fc19.i686
libX11-devel-1.6.0-1.fc19.i686
dbus-x11-1.6.12-1.fc19.i686
xorg-x11-fonts-Type1-7.5-8.fc19.noarch
xorg-x11-drv-qxl-0.1.1-0.11.20130514git77a1594.fc19.i686
xorg-x11-server-Xorg-1.14.3-2.fc19.i686
xorg-x11-proto-devel-7.7-4.fc19.noarch
xorg-x11-drv-openchrome-0.3.3-1.fc19.i686
xorg-x11-font-utils-7.5-17.fc19.i686
xorg-x11-drv-vmmouse-13.0.0-5.fc19.i686
xorg-x11-xkb-utils-7.7-7.fc19.i686
xorg-x11-drv-nouveau-1.0.9-1.fc19.i686
libX11-common-1.6.0-1.fc19.noarch
xorg-x11-glamor-0.5.0-5.20130401git81aadb8.fc19.i686
xorg-x11-drv-vmware-13.0.1-1.fc19.i686
xorg-x11-drv-fbdev-0.4.3-9.fc19.i686
pulseaudio-module-x11-3.0-10.fc19.i686
xorg-x11-utils-7.5-9.fc19.i686
xorg-x11-drv-evdev-2.8.1-2.fc19.i686
xorg-x11-drv-geode-2.11.14-6.fc19.i686
xorg-x11-server-utils-7.7-1.fc19.i686
============================================================
I join a full dmesg > dmesg.log which contains information about conflict if it may help.
Comment 6 Pierre Conti 2013-11-04 10:22:52 EST
Created attachment 819225 [details]
full dmesg containing a lot of nouveau and kernel traces
Comment 7 Ron Yorston 2013-11-06 03:57:37 EST
The situation has improved.  The most serious issue, the shell getting stuck using 100% of CPU on login, hasn't happened for some time.  The other problems are just cosmetic.
Comment 8 Ron Yorston 2013-12-07 04:45:06 EST
The situation has got worse again. Recently the shell has been getting stuck on about 50% of boots. Today was exceptional: I had to boot six times before I got a working desktop.

What with this on my desktop system and 1013867 on my laptop F19 is, for me, the worst Fedora for years.  Possibly ever.
Comment 9 Fedora End Of Life 2015-01-09 14:16:33 EST
This message is a notice that Fedora 19 is now at end of life. Fedora 
has stopped maintaining and issuing updates for Fedora 19. It is 
Fedora's policy to close all bug reports from releases that are no 
longer maintained. Approximately 4 (four) weeks from now this bug will
be closed as EOL if it remains open with a Fedora 'version' of '19'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 19 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 10 Fedora End Of Life 2015-02-17 11:33:51 EST
Fedora 19 changed to end-of-life (EOL) status on 2015-01-06. Fedora 19 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.