Bug 991820 - krdc hangs with eagain does not show windows login screen
krdc hangs with eagain does not show windows login screen
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kdenetwork (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-04 12:02 EDT by Stephen Murray
Modified: 2013-08-27 19:23 EDT (History)
8 users (show)

See Also:
Fixed In Version: kdenetwork-4.10.5-4.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-27 19:23:11 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stephen Murray 2013-08-04 12:02:52 EDT
Description of problem:
After updating krdc to level 4.10.5-1 it no longer brings up a login display to the remote Windows desktop. strace indicates it is looping with EAGAIN.

Version-Release number of selected component (if applicable):
kdenetwork-krdc-4.10.5-1.fc19.x86_64
kdenetwork-krdc-libs-4.10.5-1.fc19.x86_64

How reproducible:
Just run krdc (command line or GUI) and try to connect to a remote Windows system. I happen to be connecting to a pair of Windows 7 Professional 32bit desktops, and a Windows 2008 64bit server.

Steps to Reproduce:
1. Install kdenetwork-krdc-4.10.5-1.fc19.x86_64
2. Run krdc
3.

Actual results:
From "strace krdc", these lines repeat:

poll([{fd=3, events=POLLIN}, {fd=7, events=POLLIN}, {fd=8, events=POLLIN}, {fd=9, events=POLLIN}, {fd=6, events=POLLIN}, {fd=10, events=POLLIN}, {fd=13, events=POLLIN}, {fd=15, events=POLLIN}], 8, 0) = 0 (Timeout)
recvfrom(6, 0x2508e24, 4096, 0, 0, 0)   = -1 EAGAIN (Resource temporarily unavailable)
recvfrom(6, 0x2508e24, 4096, 0, 0, 0)   = -1 EAGAIN (Resource temporarily unavailable)
poll([{fd=3, events=POLLIN}, {fd=7, events=POLLIN}, {fd=8, events=POLLIN}, {fd=9, events=POLLIN}, {fd=6, events=POLLIN}, {fd=10, events=POLLIN}, {fd=13, events=POLLIN}, {fd=15, events=POLLIN}], 8, 0) = 0 (Timeout)
recvfrom(6, 0x2508e24, 4096, 0, 0, 0)   = -1 EAGAIN (Resource temporarily unavailable)
recvfrom(6, 0x2508e24, 4096, 0, 0, 0)   = -1 EAGAIN (Resource temporarily unavailable)

Expected results:
Windows login screen to be displayed.

Additional info:
After downgrading to kdenetwork-krdc-4.10.4-1.fc19.x86_64 krdc works as expected.
Comment 1 Rex Dieter 2013-08-04 12:36:05 EDT
Looks like our backport of using freerpd instead of rdesktop has problems. :(

Does manually using xfreerdp work or not for you?
Comment 2 Stephen Murray 2013-08-04 12:48:07 EDT
Yes, xfreerdp is working correctly. It logs me in to the remote Windows desktop.

xfreerdp -u username hostname.fqdn

I've never used xfreerdp before, I'll play around with it too.
Comment 3 Fedora Update System 2013-08-14 09:34:19 EDT
kdenetwork-4.10.5-4.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/kdenetwork-4.10.5-4.fc19
Comment 4 Fedora Update System 2013-08-14 23:00:23 EDT
Package kdenetwork-4.10.5-4.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kdenetwork-4.10.5-4.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14782/kdenetwork-4.10.5-4.fc19
then log in and leave karma (feedback).
Comment 5 Stephen Murray 2013-08-16 16:36:44 EDT
I installed the updated packages, it has fixed the problem. Thanks !

[murraysj@localhost ~]$ rpm -qa | grep kdenetwork
kdenetwork-krdc-libs-4.10.5-4.fc19.x86_64
kdenetwork-common-4.10.5-4.fc19.noarch
kdenetwork-krdc-4.10.5-4.fc19.x86_64
[murraysj@localhost ~]
Comment 6 Fedora Update System 2013-08-27 19:23:11 EDT
kdenetwork-4.10.5-4.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.