Bug 991837 - SELinux is preventing /usr/sbin/abrt-dbus from 'remove_name' accesses on the directory .lock.
SELinux is preventing /usr/sbin/abrt-dbus from 'remove_name' accesses on the ...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
18
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:6c41854d20cac3555a32db867bc...
:
: 991838 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-04 19:38 EDT by Moez Roy
Modified: 2013-08-05 03:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-05 03:55:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Moez Roy 2013-08-04 19:38:42 EDT
Description of problem:
SELinux is preventing /usr/sbin/abrt-dbus from 'remove_name' accesses on the directory .lock.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that abrt-dbus should be allowed remove_name access on the .lock directory by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep abrt-dbus /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:abrt_t:s0-s0:c0.c1023
Target Context                unconfined_u:object_r:cache_home_t:s0
Target Objects                .lock [ dir ]
Source                        abrt-dbus
Source Path                   /usr/sbin/abrt-dbus
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           abrt-dbus-2.1.6-2.fc18.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.11.1-98.fc18.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Permissive
Host Name                     (removed)
Platform                      Linux (removed) 3.9.11-200.fc18.x86_64 #1 SMP Mon
                              Jul 22 21:04:50 UTC 2013 x86_64 x86_64
Alert Count                   1
First Seen                    2013-08-04 16:38:01 PDT
Last Seen                     2013-08-04 16:38:01 PDT
Local ID                      cd76a960-5123-4851-9dcc-23c548b18a63

Raw Audit Messages
type=AVC msg=audit(1375659481.119:307): avc:  denied  { remove_name } for  pid=2109 comm="abrt-dbus" name=".lock" dev="dm-1" ino=786828 scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=unconfined_u:object_r:cache_home_t:s0 tclass=dir


type=AVC msg=audit(1375659481.119:307): avc:  denied  { unlink } for  pid=2109 comm="abrt-dbus" name=".lock" dev="dm-1" ino=786828 scontext=system_u:system_r:abrt_t:s0-s0:c0.c1023 tcontext=system_u:object_r:cache_home_t:s0 tclass=lnk_file


type=SYSCALL msg=audit(1375659481.119:307): arch=x86_64 syscall=unlink success=yes exit=0 a0=7fff8530af40 a1=7fb00351b530 a2=7fb0002b9052 a3=7fff8530acc0 items=0 ppid=1 pid=2109 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=abrt-dbus exe=/usr/sbin/abrt-dbus subj=system_u:system_r:abrt_t:s0-s0:c0.c1023 key=(null)

Hash: abrt-dbus,abrt_t,cache_home_t,dir,remove_name

audit2allow

#============= abrt_t ==============
allow abrt_t cache_home_t:dir remove_name;
allow abrt_t cache_home_t:lnk_file unlink;

audit2allow -R
require {
	type cache_home_t;
	type abrt_t;
	class lnk_file unlink;
}

#============= abrt_t ==============
allow abrt_t cache_home_t:lnk_file unlink;
thumb_filetrans_home_content(abrt_t)


Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.9.11-200.fc18.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-08-05 02:27:23 EDT
*** Bug 991838 has been marked as a duplicate of this bug. ***
Comment 2 Miroslav Grepl 2013-08-05 03:55:19 EDT
Please execute

# restorecon -R -v /var/tmp/abrt

Note You need to log in before you can comment on or make changes to this bug.