Bug 991840 - MRG Search Whine returning no results
MRG Search Whine returning no results
Status: CLOSED WONTFIX
Product: Bugzilla
Classification: Community
Component: Whining (Show other bugs)
4.4
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: Simon Green
tools-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-04 19:51 EDT by John Skeoch
Modified: 2014-10-12 18:51 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-28 23:48:38 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Skeoch 2013-08-04 19:51:03 EDT
I have recently, just now, shared the search in question. Keep in mind, the search works perfectly.

https://bugzilla.redhat.com/buglist.cgi?cmdtype=dorem&remaction=run&namedcmd=MRG%2FM-QA_Unassigned&sharer_id=210798

The whine is set up as the attached image shows and was working until recently. Each morning instead of getting the search results expected, I receive an email stating their were no results.

[email]
SUBJ: [Red Hat Bugzilla] mrg-bugs require qa attention
Click here to edit your whine schedule

No bugs were found that matched the search criteria.
[/email]

July 29 was the last day this whine worked.

Thank you!
Eric

I have whining set up to report MRG Bugs that are currently unassigned. This whine was working up until recently; however, the past few times the delivered report shows "No bugs were found that matched the search criteria.". When I run the exact same saved search I get 68 results. My search used for the whine and the whine have remained unchanged; however, this issue seems to have developed after the most recent Bugzilla maintenance / update.

Thank you!

-- 

Eric L. Sammons esammons at redhat dot com
Manager Quality Engineering irc: lytrogeek
Red Hat Quality Engineering 919.754.4963 (w)
rhce # 805007668329332 919.889.3279 (c)
rhcva # 805007668329332
Comment 1 Simon Green 2013-08-28 23:48:38 EDT
(copied from an e-mail that was sent to people originally affected by this problem)

You are receiving this e-mail as you have a whine that is not working since we upgraded to Red Hat Bugzilla 4.4. A change in Bugzilla 4.4 (from upstream) is that whines will now send out the columns that you have in your search (if specified) rather than a preset list of columns.

Additionally, the whine in question was created in Red Hat Bugzilla 3.6 (or earlier) and included 'flag names' as one of the fields to display. Between Bugzilla 3.6 and 4.2, the field name was changed. If you viewed the query via your browser, you would have noticed the flag types column no longer shows.

These are the instructions to fix the problem:

1) Log into Red Hat Bugzilla at https://bugzilla.redhat.com/
2) Click on the saved search that is causing the problem.
3) Click on 'Edit Search'
4) Click on the 'Search' button at the bottom of the page.
5) In the URL change '%2Cflags' to '%2Cflagtypes.name', and visit that URL.
6) Click the 'Remember search' button.

Your whine should now run at the scheduled time. If you prefer, you can reply to this e-mail, and I can make the change for you.

Note You need to log in before you can comment on or make changes to this bug.