Bug 991855 - SELinux is preventing /usr/sbin/plymouthd from using the 'execmem' accesses on a process.
SELinux is preventing /usr/sbin/plymouthd from using the 'execmem' accesses o...
Status: CLOSED DUPLICATE of bug 880953
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:d53656b219b7083d03435d68327...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-04 21:41 EDT by Arkangel75ar
Modified: 2013-10-25 05:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-25 05:44:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Arkangel75ar 2013-08-04 21:41:07 EDT
Description of problem:
SELinux is preventing /usr/sbin/plymouthd from using the 'execmem' accesses on a process.

*****  Plugin catchall (100. confidence) suggests  ***************************

If cree que de manera predeterminada, plymouthd debería permitir acceso execmem sobre procesos etiquetados como plymouthd_t.
Then debería reportar esto como un error.
Puede generar un módulo de política local para permitir este acceso.
Do
permita el acceso momentáneamente executando:
# grep plymouthd /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:plymouthd_t:s0
Target Context                system_u:system_r:plymouthd_t:s0
Target Objects                 [ process ]
Source                        plymouthd
Source Path                   /usr/sbin/plymouthd
Port                          <Desconocido>
Host                          (removed)
Source RPM Packages           plymouth-0.8.9-0.2013.03.26.0.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-66.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.9-302.fc19.x86_64 #1 SMP Sat
                              Jul 6 13:41:07 UTC 2013 x86_64 x86_64
Alert Count                   3
First Seen                    2013-08-04 20:17:19 ADT
Last Seen                     2013-08-04 21:33:03 ADT
Local ID                      f0ce6bc4-47db-421f-a078-d01849bf84ab

Raw Audit Messages
type=AVC msg=audit(1375662783.934:451): avc:  denied  { execmem } for  pid=1184 comm="plymouthd" scontext=system_u:system_r:plymouthd_t:s0 tcontext=system_u:system_r:plymouthd_t:s0 tclass=process


type=SYSCALL msg=audit(1375662783.934:451): arch=x86_64 syscall=mmap success=no exit=EACCES a0=38a87c2000 a1=28000 a2=7 a3=812 items=0 ppid=1 pid=1184 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 ses=4294967295 tty=(none) comm=plymouthd exe=/usr/sbin/plymouthd subj=system_u:system_r:plymouthd_t:s0 key=(null)

Hash: plymouthd,plymouthd_t,plymouthd_t,process,execmem

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.9.9-302.fc19.x86_64
type:           libreport

Potential duplicate: bug 880953
Comment 1 Daniel Walsh 2013-08-05 13:09:56 EDT
Did you change the plymouth screens?
Comment 2 Lukas Vrabec 2013-10-25 05:44:13 EDT

*** This bug has been marked as a duplicate of bug 880953 ***

Note You need to log in before you can comment on or make changes to this bug.