This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 991871 - perl-Qt: FTBFS in rawhide
perl-Qt: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-Qt (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Iain Arnell
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F20FTBFS 991914
  Show dependency treegraph
 
Reported: 2013-08-04 22:52 EDT by Dennis Gilmore
Modified: 2013-08-31 04:29 EDT (History)
5 users (show)

See Also:
Fixed In Version: perl-Qt-0.96.0-9.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-31 04:29:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Update spec to use current upstream (2.12 KB, patch)
2013-08-06 08:00 EDT, Paul Howarth
no flags Details | Diff

  None (edit)
Description Dennis Gilmore 2013-08-04 22:52:02 EDT
Your package perl-Qt failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=5661463

Build logs:
root.log: http://kojipkgs.fedoraproject.org/work/tasks/1463/5661463/root.log
build.log: http://kojipkgs.fedoraproject.org/work/tasks/1463/5661463/build.log
state.log: http://kojipkgs.fedoraproject.org/work/tasks/1463/5661463/state.log
NOTE: build logs are cleaned up after 1 week

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
Comment 1 Paul Howarth 2013-08-06 08:00:58 EDT
Created attachment 783291 [details]
Update spec to use current upstream

It looks like the development of Perl QT bindings takes place on code.google.com now, and releases are done as part of KDE releases.

Unfortunately there still doesn't seem to be much activity upstream, and the same tests are failing in the current stable release. I have raised the Perl 5.18 test failure issue upstream here:

http://code.google.com/p/perlqt4/issues/detail?id=54
Comment 2 Oron Peled 2013-08-24 08:38:28 EDT
Looks like upstream has pushed a fix:
   http://code.google.com/p/perlqt4/issues/detail?id=54#c3

The code is indeed in kde.org:
   http://quickgit.kde.org/?p=perlqt.git

Fixing it would fix bug #991914 as well (FTBFS debconf)
Comment 3 Paul Howarth 2013-08-31 04:29:25 EDT
I've applied the two commits from upstream (skipping a couple of hunks that didn't apply, one for the cmake buildsystem that changed a file that doesn't exist in the old CPAN version, and one for a GUI test that doesn't get run during the build anyway), and the package now builds.

I still think it would be a good idea to switch upstreams to the KDE one.

Note You need to log in before you can comment on or make changes to this bug.