Bug 991889 - dyninst: FTBFS in rawhide
dyninst: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dyninst (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: William Cohen
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F20FTBFS
  Show dependency treegraph
 
Reported: 2013-08-04 22:53 EDT by Dennis Gilmore
Modified: 2013-08-05 13:53 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-05 13:53:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Avoid including <linux/ptrace.h> (2.21 KB, patch)
2013-08-05 12:54 EDT, William Cohen
no flags Details | Diff

  None (edit)
Description Dennis Gilmore 2013-08-04 22:53:57 EDT
Your package dyninst failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=5677602

Build logs:
root.log: http://kojipkgs.fedoraproject.org/work/tasks/7602/5677602/root.log
build.log: http://kojipkgs.fedoraproject.org/work/tasks/7602/5677602/build.log
state.log: http://kojipkgs.fedoraproject.org/work/tasks/7602/5677602/state.log
NOTE: build logs are cleaned up after 1 week

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
Comment 1 Frank Ch. Eigler 2013-08-05 08:41:57 EDT
Salient bits of build log:

symLite build voucher being constructed for libsymLite: BUILD#0
../../scripts/buildstamp: line 108: hostname: command not found
     $symLite: v8.1.2-1 libsymLite #0 2013/07/30 11:57 mockbuild@ $
Compiling V_libsymLite.o

g++ -c -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches  -m64 -mtune=generic -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches  -m64 -mtune=generic -std=c++11  -I../h -I. -I. -I./dynutil/h -I./external -Darch_x86_64 -Darch_64bit -Dos_linux  -Dcap_ptrace -Dcap_stripped_binaries -Dcap_async_events -Dcap_relocation -Dcap_dwarf -Dcap_32_64 -Dcap_fixpoint_gen -Dcap_noaddr_gen -Dcap_mutatee_traps -Dcap_binary_rewriter -Dcap_registers -Dcap_instruction_api -Dcap_serialization -Dcap_instruction_replacement -Dcap_tramp_liveness -Dcap_thread_db -Dcap_gnu_demangler -Ddwarf_has_setframe -Dbug_syscall_changepc_rewind -Dbug_force_terminate_failure -Dx86_64_unknown_linux2_4 -DPACKAGE_NAME=\"Dyninst\" -DPACKAGE_TARNAME=\"dyninst\" -DPACKAGE_VERSION=\"8.1.1\" -DPACKAGE_STRING=\"Dyninst\ 8.1.1\" -DPACKAGE_BUGREPORT=\"bugs@dyninst.org\" -DHAVE_BOOST=1 -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_LIBELF=1 -DHAVE_LIBTHREAD_DB=1 -O2  -D__STDC_LIMIT_MACROS -D__STDC_CONSTANT_MACROS  -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches  -m64 -mtune=generic -std=c++11 -fimplicit-templates -D_REENTRANT=1 -Dcap_mmtimer -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches  -m64 -mtune=generic -std=c++11  -I../h -I. -I../.. -I../../dynutil/h -I../../external -I../src -I../h -Darch_x86_64 -Darch_64bit -Dos_linux  -Dcap_ptrace -Dcap_stripped_binaries -Dcap_async_events -Dcap_relocation -Dcap_dwarf -Dcap_32_64 -Dcap_fixpoint_gen -Dcap_noaddr_gen -Dcap_mutatee_traps -Dcap_binary_rewriter -Dcap_registers -Dcap_instruction_api -Dcap_serialization -Dcap_instruction_replacement -Dcap_tramp_liveness -Dcap_thread_db -Dcap_gnu_demangler -Ddwarf_has_setframe -Dbug_syscall_changepc_rewind -Dbug_force_terminate_failure -Dx86_64_unknown_linux2_4 -DPACKAGE_NAME=\"Dyninst\" -DPACKAGE_TARNAME=\"dyninst\" -DPACKAGE_VERSION=\"8.1.1\" -DPACKAGE_STRING=\"Dyninst\ 8.1.1\" -DPACKAGE_BUGREPORT=\"bugs@dyninst.org\" -DHAVE_BOOST=1 -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_LIBELF=1 -DHAVE_LIBTHREAD_DB=1 -O2  -D__STDC_LIMIT_MACROS -D__STDC_CONSTANT_MACROS  -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches  -m64 -mtune=generic -std=c++11 -fimplicit-templates -D_REENTRANT=1 -Dcap_mmtimer -fPIC -I/usr/include/libdwarf -DLIBELF_PLATFORM -DCOMPONENT_NAME=ProcControlAPI -W -Wall -Wpointer-arith -Wcast-qual -Woverloaded-virtual -Wcast-align -Wno-non-template-friend    ../src/linux.C -o linux.o
In file included from ../../proccontrol/src/linux.h:50:0,
                 from ../src/linux.C:58:
/usr/include/linux/ptrace.h:58:8: error: redefinition of 'struct ptrace_peeksiginfo_args'
 struct ptrace_peeksiginfo_args {
        ^
In file included from ../../common/h/linuxHeaders.h:53:0,
                 from ../../common/h/headers.h:56,
                 from ../../common/h/pathName.h:37,
                 from ../src/linux.C:47:
/usr/include/sys/ptrace.h:191:8: error: previous definition of 'struct ptrace_peeksiginfo_args'
 struct ptrace_peeksiginfo_args
        ^
Comment 2 William Cohen 2013-08-05 12:54:07 EDT
Created attachment 782935 [details]
Avoid including <linux/ptrace.h>

It looks like the code was using some old defines from <linux/ptrace.h>. Updated those to the current definitions and eliminate the need for including <linux/ptrace.h>
Comment 3 William Cohen 2013-08-05 13:53:00 EDT
dyninst-8.1.2-4 successfully built:

http://koji.fedoraproject.org/koji/taskinfo?taskID=5780218

Note You need to log in before you can comment on or make changes to this bug.