Bug 991927 - 389-admin: FTBFS in rawhide
389-admin: FTBFS in rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: 389-admin (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Rich Megginson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F20FTBFS
  Show dependency treegraph
 
Reported: 2013-08-04 22:57 EDT by Dennis Gilmore
Modified: 2014-01-14 03:40 EST (History)
6 users (show)

See Also:
Fixed In Version: 389-admin-1.1.35-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-20 16:53:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2013-08-04 22:57:49 EDT
Your package 389-admin failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=5694267

Build logs:
root.log: http://kojipkgs.fedoraproject.org/work/tasks/4267/5694267/root.log
build.log: http://kojipkgs.fedoraproject.org/work/tasks/4267/5694267/build.log
state.log: http://kojipkgs.fedoraproject.org/work/tasks/4267/5694267/state.log
NOTE: build logs are cleaned up after 1 week

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
Comment 1 Petr Pisar 2013-08-06 06:51:45 EDT
configure: checking for ADMINUTIL...
checking for --with-adminutil... no
checking for adminutil with pkg-config... checking for pkg-config... (cached) /usr/bin/i686-redhat-linux-gnu-pkg-config
configure: error: ADMINUTIL not found, specify with --with-adminutil.

Missing a dependency?
Comment 2 Adam Williamson 2013-08-06 17:14:55 EDT
I don't think it's a missing dependency, the package has:

BuildRequires:    389-adminutil-devel

I note, though, that the pkgconfig file is /usr/lib64/pkgconfig/389-adminutil.pc - perhaps the library's pkgconfig name changed and 389-admin's build scripts weren't adjusted?
Comment 3 Rich Megginson 2013-08-06 17:21:01 EDT
(In reply to Adam Williamson from comment #2)
> I don't think it's a missing dependency, the package has:
> 
> BuildRequires:    389-adminutil-devel
> 
> I note, though, that the pkgconfig file is
> /usr/lib64/pkgconfig/389-adminutil.pc - perhaps the library's pkgconfig name
> changed and 389-admin's build scripts weren't adjusted?

It's been this way since . . . F-14?  And now all of a sudden in F-20 it stops working?
Comment 4 Adam Williamson 2013-08-06 17:41:40 EDT
See comments #5 and #6 on https://bugzilla.redhat.com/show_bug.cgi?id=991928 . I did as much digging into this as I could manage. Hope it helps.
Comment 5 Rich Megginson 2013-08-07 16:58:38 EDT
Upstream ticket:
https://fedorahosted.org/389/ticket/47465
Comment 6 Fedora Update System 2013-08-20 15:51:50 EDT
389-admin-1.1.35-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/389-admin-1.1.35-1.fc19
Comment 7 Fedora Update System 2013-08-20 15:52:23 EDT
389-admin-1.1.35-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/389-admin-1.1.35-1.fc18
Comment 8 Fedora Update System 2013-09-29 20:36:33 EDT
389-admin-1.1.35-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 9 Fedora Update System 2014-01-14 03:40:21 EST
389-admin-1.1.35-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.