This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 992008 - axis: FTBFS in rawhide
axis: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: axis (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Mat Booth
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F20FTBFS
  Show dependency treegraph
 
Reported: 2013-08-04 23:05 EDT by Dennis Gilmore
Modified: 2013-08-07 06:31 EDT (History)
5 users (show)

See Also:
Fixed In Version: axis-1.4-22
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-07 06:31:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2013-08-04 23:05:58 EDT
Your package axis failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=5698606

Build logs:
root.log: http://kojipkgs.fedoraproject.org/work/tasks/8606/5698606/root.log
build.log: http://kojipkgs.fedoraproject.org/work/tasks/8606/5698606/build.log
state.log: http://kojipkgs.fedoraproject.org/work/tasks/8606/5698606/state.log
NOTE: build logs are cleaned up after 1 week

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
Comment 1 Krzysztof Daniel 2013-08-06 06:56:14 EDT
it looks like API change

beyond my knowledge:

[javac] /builddir/build/BUILD/axis-1.4-src/src/org/apache/axis/message/NodeImpl.java:45: error: NodeImpl is not abstract and does not override abstract method getUserData(String) in Node
    [javac] public class NodeImpl implements org.w3c.dom.Node, javax.xml.soap.Node,
    [javac]        ^
    [javac] /builddir/build/BUILD/axis-1.4-src/src/org/apache/axis/message/MessageElement.java:73: error: MessageElement is not abstract and does not override abstract method getUserData(String) in Node
    [javac] public class MessageElement extends NodeImpl implements SOAPElement,
    [javac]        ^
    [javac] /builddir/build/BUILD/axis-1.4-src/src/org/apache/axis/message/SOAPHeaderElement.java:40: error: SOAPHeaderElement is not abstract and does not override abstract method getUserData(String) in Node
    [javac] public class SOAPHeaderElement extends MessageElement
    [javac]        ^
    [javac] /builddir/build/BUILD/axis-1.4-src/src/org/apache/axis/SOAPPart.java:90: error: SOAPPart is not abstract and does not override abstract method renameNode(Node,String,String) in Document
    [javac] public class SOAPPart extends javax.xml.soap.SOAPPart implements Part
    [javac]        ^
    [javac] /builddir/build/BUILD/axis-1.4-src/src/org/apache/axis/message/SOAPEnvelope.java:50: error: SOAPEnvelope is not abstract and does not override abstract method getUserData(String) in Node
    [javac] public class SOAPEnvelope extends MessageElement
    [javac]        ^
    [javac] /builddir/build/BUILD/axis-1.4-src/src/org/apache/axis/message/SOAPHeader.java:50: error: SOAPHeader is not abstract and does not override abstract method getUserData(String) in Node
    [javac] public class SOAPHeader extends MessageElement
    [javac]        ^
    [javac] /builddir/build/BUILD/axis-1.4-src/src/org/apache/axis/message/SOAPBody.java:46: error: SOAPBody is not abstract and does not override abstract method getUserData(String) in Node
    [javac] public class SOAPBody extends MessageElement
    [javac]        ^
    [javac] /builddir/build/BUILD/axis-1.4-src/src/org/apache/axis/message/SOAPBodyElement.java:37: error: SOAPBodyElement is not abstract and does not override abstract method getUserData(String) in Node
Comment 2 Mat Booth 2013-08-07 06:31:32 EDT
axis-1.4-22 is now built for rawhide:

http://koji.fedoraproject.org/koji/buildinfo?buildID=454859

Note You need to log in before you can comment on or make changes to this bug.