Bug 992171 - eclipse-linuxtools: FTBFS in rawhide
eclipse-linuxtools: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: eclipse-linuxtools (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Roland Grunberg
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F20FTBFS
  Show dependency treegraph
 
Reported: 2013-08-04 23:27 EDT by Dennis Gilmore
Modified: 2013-08-06 14:52 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-06 14:52:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2013-08-04 23:27:51 EDT
Your package eclipse-linuxtools failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=5711138

Build logs:
root.log: http://kojipkgs.fedoraproject.org/work/tasks/1138/5711138/root.log
build.log: http://kojipkgs.fedoraproject.org/work/tasks/1138/5711138/build.log
state.log: http://kojipkgs.fedoraproject.org/work/tasks/1138/5711138/state.log
NOTE: build logs are cleaned up after 1 week

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
Comment 1 Roland Grunberg 2013-08-06 11:48:40 EDT
This is only happening on armv7hl. I'm able to successfully build on other architectures. Could this be in any way related to some of the recent changes made to eclipse ?
Comment 2 Roland Grunberg 2013-08-06 12:14:49 EDT
Actually this is Bug 863801. Disabling the JIT for EquinoxResolver#newState (as does Eclipse) during compilation solved the issue.

Note You need to log in before you can comment on or make changes to this bug.