Bug 99252 - Opteron: When I force PCIMode I get a looping RADEONCPBuffer Error
Opteron: When I force PCIMode I get a looping RADEONCPBuffer Error
Status: CLOSED DUPLICATE of bug 86157
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
GinGin64
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-16 13:36 EDT by Mark Lane
Modified: 2007-04-18 12:55 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 13:57:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mark Lane 2003-07-16 13:36:45 EDT
Description:
I have a MSI K8D Dual Opteron Board and I am having problems getting DRI 
support to work for any Radeon PCI cards. I have tried both a 7000 and 7500. 
Both cause a rapidly looping error when X starts up with the "ForcePCIMode" 
option.

(EE) RADEON(0): GetBuffer timed out, resetting engine...
(EE) RADEON(0): RADEONCPGetBuffer: CP reset -1020
(EE) RADEON(0): RADEONCPGetBuffer: CP start -1020
(EE) RADEON(0): RADEONCPGetBuffer: CP GetBuffer -1020
(EE) RADEON(0): GetBuffer timed out, resetting engine...
(EE) RADEON(0): RADEONCPGetBuffer: CP reset -1020
(EE) RADEON(0): RADEONCPGetBuffer: CP start -1020
(EE) RADEON(0): RADEONCPGetBuffer: CP GetBuffer -1020
(EE) RADEON(0): GetBuffer timed out, resetting engine...

I understand some work may have been done on the DRI CVS with regards to the 
Radeon PCIGard but I was having problems compiling monday's snapshot on the 
Opteron.

The machine is having some hardware work done at present so I can't get the 
exact packages but I am pretty sure they packages are stock. Some updates were 
run so it is possible that the system is running the newest RedHat kernel.

Steps to Reproduce:
1. Setup X for Radeon
2. Modify XF86Config to "ForcePCIMode"
3. Startx

Actual Results:
The system becomes unresponsive and fills the XFree86.0.log repeatly with the 
following message.

(EE) RADEON(0): GetBuffer timed out, resetting engine...
(EE) RADEON(0): RADEONCPGetBuffer: CP reset -1020
(EE) RADEON(0): RADEONCPGetBuffer: CP start -1020
(EE) RADEON(0): RADEONCPGetBuffer: CP GetBuffer -1020
(EE) RADEON(0): GetBuffer timed out, resetting engine...
(EE) RADEON(0): RADEONCPGetBuffer: CP reset -1020
(EE) RADEON(0): RADEONCPGetBuffer: CP start -1020
(EE) RADEON(0): RADEONCPGetBuffer: CP GetBuffer -1020
(EE) RADEON(0): GetBuffer timed out, resetting engine...

Expected Results:
X starts up and glxinfo shows DRI enabled.

Additional Information:
Dual Opteron 240
MSI K8D Motherboard
3ware 7000-2
120GB Western Digital JB
64MB Radeon 7500 or 7000
VIA 3 Port Firewire Adaptor
GinGin64 Beta
2x1GB PC2100 4x64 Reg ECC
Comment 1 Mike A. Harris 2003-07-16 16:09:47 EDT

*** This bug has been marked as a duplicate of 86157 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:57:04 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.