Bug 992531 - SELinux is preventing /usr/bin/gnome-thumbnail-font from 'append' accesses on the unix_stream_socket unix_stream_socket.
SELinux is preventing /usr/bin/gnome-thumbnail-font from 'append' accesses on...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:45be797499198566187d1d74cc4...
:
: 993032 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-05 01:26 EDT by abyss.7
Modified: 2013-08-21 20:52 EDT (History)
12 users (show)

See Also:
Fixed In Version: selinux-policy-3.12.1-71.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-21 20:52:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description abyss.7 2013-08-05 01:26:58 EDT
Description of problem:
Run gnome-font-viewer
SELinux is preventing /usr/bin/gnome-thumbnail-font from 'append' accesses on the unix_stream_socket unix_stream_socket.

*****  Plugin leaks (86.2 confidence) suggests  ******************************

If you want to ignore gnome-thumbnail-font trying to append access the unix_stream_socket unix_stream_socket, because you believe it should not need this access.
Then you should report this as a bug.  
You can generate a local policy module to dontaudit this access.
Do
# grep /usr/bin/gnome-thumbnail-font /var/log/audit/audit.log | audit2allow -D -M mypol
# semodule -i mypol.pp

*****  Plugin catchall (14.7 confidence) suggests  ***************************

If you believe that gnome-thumbnail-font should be allowed append access on the unix_stream_socket unix_stream_socket by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep gnome-thumbnail /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023
Target Context                unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1
                              023
Target Objects                unix_stream_socket [ unix_stream_socket ]
Source                        gnome-thumbnail
Source Path                   /usr/bin/gnome-thumbnail-font
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           gnome-font-viewer-3.8.0-1.fc19.x86_64
Target RPM Packages           
Policy RPM                    selinux-policy-3.12.1-66.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.10.4-300.fc19.x86_64 #1 SMP Tue
                              Jul 30 11:29:05 UTC 2013 x86_64 x86_64
Alert Count                   77
First Seen                    2013-08-05 09:25:38 MSK
Last Seen                     2013-08-05 09:25:40 MSK
Local ID                      90e5dac2-e3d9-4d1a-8eb7-33ef81a596e8

Raw Audit Messages
type=AVC msg=audit(1375680340.331:1826): avc:  denied  { append } for  pid=13052 comm="gnome-thumbnail" path="socket:[1066484]" dev="sockfs" ino=1066484 scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=unix_stream_socket


type=AVC msg=audit(1375680340.331:1826): avc:  denied  { append } for  pid=13052 comm="gnome-thumbnail" path="socket:[1066484]" dev="sockfs" ino=1066484 scontext=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 tcontext=unconfined_u:unconfined_r:unconfined_t:s0-s0:c0.c1023 tclass=unix_stream_socket


type=SYSCALL msg=audit(1375680340.331:1826): arch=x86_64 syscall=execve success=yes exit=0 a0=7ff960002980 a1=7ff960002b20 a2=7fffabcd7ab8 a3=3590c86e20 items=0 ppid=12842 pid=13052 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 ses=64 tty=(none) comm=gnome-thumbnail exe=/usr/bin/gnome-thumbnail-font subj=unconfined_u:unconfined_r:thumb_t:s0-s0:c0.c1023 key=(null)

Hash: gnome-thumbnail,thumb_t,unconfined_t,unix_stream_socket,append

Additional info:
reporter:       libreport-2.1.5
hashmarkername: setroubleshoot
kernel:         3.10.4-300.fc19.x86_64
type:           libreport
Comment 1 Daniel Walsh 2013-08-05 12:31:05 EDT
*** Bug 993032 has been marked as a duplicate of this bug. ***
Comment 2 Daniel Walsh 2013-08-05 12:39:07 EDT
Added dontaudit rule.

1e7df10d9d4d31e4f2f877aee72fdc0f8287403d
Comment 3 Michal Nowak 2013-08-06 05:13:45 EDT
Description of problem:
Opened Nautilus and e-t probably started to create thumbnails.

Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.10.4-300.fc19.x86_64
type:           libreport
Comment 4 Rodd Clarkson 2013-08-08 00:08:55 EDT
Description of problem:
Just using my system

Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.10.4-300.fc19.x86_64
type:           libreport
Comment 5 Miroslav Grepl 2013-08-08 07:34:41 EDT
Back ported.
Comment 6 Joel R. 2013-08-17 12:58:54 EDT
Description of problem:
I think the system was simply trying to create a preview of a .avi file on an external USB hard drive.

Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.10.6-200.fc19.x86_64
type:           libreport
Comment 7 Sean Myers 2013-08-17 15:27:42 EDT
Description of problem:
I downloaded and installed acroread from Adobe's yum repo, then opened an existing pdf in nautilus.

Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.10.5-201.fc19.x86_64
type:           libreport
Comment 8 Vasilis Keramidas 2013-08-19 07:31:17 EDT
Description of problem:
Opened a pdf.

Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.10.7-200.fc19.x86_64
type:           libreport
Comment 9 Fedora Update System 2013-08-20 04:25:57 EDT
selinux-policy-3.12.1-71.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/selinux-policy-3.12.1-71.fc19
Comment 10 Fedora Update System 2013-08-20 20:15:06 EDT
Package selinux-policy-3.12.1-71.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.12.1-71.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15088/selinux-policy-3.12.1-71.fc19
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2013-08-21 20:52:54 EDT
selinux-policy-3.12.1-71.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.