Bug 992629 - Uploading file with a semicolon in the filename causes filename to be truncated
Uploading file with a semicolon in the filename causes filename to be truncated
Status: CLOSED UPSTREAM
Product: Zanata
Classification: Community
Component: Usability (Show other bugs)
development
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: David Mason
Zanata-QA Mailling List
:
Depends On: 1066694
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-05 01:46 EDT by David Mason
Modified: 2015-07-30 21:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-30 21:22:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Mason 2013-08-05 01:46:42 EDT
Description of problem:
If a filename contains a semicolon, only the component of the filename before the semicolon is used by Zanata, and a double-quote is prepended to to the filename.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create a file named test.txt;test.txt
2. Sign in as a maintainer of a project
3. Navigate to source documents page
4. Open upload dialog and select the file that has a semicolon in its name
5. Initiate the upload

Actual results:
File uploads successfully and is named (including double-quote character) "test.txt

Expected results:
File uploads successfully and is named test.txt;test.txt

Additional info:
This is caused by https://issues.jboss.org/browse/JBSEAM-4822
Comment 1 David Mason 2014-08-03 21:11:55 EDT
This problem will disappear when the seam file upload elements are replaced by the new multi-file upload widget. Once the new widget has proved stable in production, we can use it to replace all upload dialogs for which this problem occurs.
Comment 2 Zanata Migrator 2015-07-30 21:22:23 EDT
Migrated; check JIRA for bug status: http://zanata.atlassian.net/browse/ZNTA-464

Note You need to log in before you can comment on or make changes to this bug.