Bug 992707 - perl-Panotools-Script: FTBFS in rawhide
perl-Panotools-Script: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-Panotools-Script (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Bruno Postle
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F20FTBFS
  Show dependency treegraph
 
Reported: 2013-08-05 01:56 EDT by Dennis Gilmore
Modified: 2013-08-18 19:25 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-18 19:25:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2013-08-05 01:56:06 EDT
Your package perl-Panotools-Script failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=5740772

Build logs:
root.log: http://kojipkgs.fedoraproject.org/work/tasks/772/5740772/root.log
build.log: http://kojipkgs.fedoraproject.org/work/tasks/772/5740772/build.log
state.log: http://kojipkgs.fedoraproject.org/work/tasks/772/5740772/state.log
NOTE: build logs are cleaned up after 1 week

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
Comment 1 Paul Howarth 2013-08-12 18:42:47 EDT
Apologies for the noise. I tried a scratch build, which worked:
http://koji.fedoraproject.org/koji/taskinfo?taskID=5809851

So I tried a real build, and it failed:
http://koji.fedoraproject.org/koji/taskinfo?taskID=5809877

Failing code looks quite simple, but I just can't see what's wrong. Time for more coffee perhaps.
Comment 2 Bruno Postle 2013-08-16 14:30:43 EDT
(In reply to Paul Howarth from comment #1)
> 
> Failing code looks quite simple, but I just can't see what's wrong. Time for
> more coffee perhaps.

This test has been failing randomly since perl 5.17.*

I *think* it is because there is a sub that declares $a and $b as local variables, but perl now treats them as globals, so it goes bad when the sub is called within sort().

There is an untested fix upstream: http://sourceforge.net/p/panotools/Panotools-Script/ci/f973ab7af9dd55a4f3f4d8cab7a957afc6ef5c01/

So this needs a new Panotools::Script release.
Comment 3 Bruno Postle 2013-08-18 19:25:06 EDT
Fixed with the new 0.28 release, actually have no idea what was wrong with the old code, could be a perl bug. 

http://koji.fedoraproject.org/koji/taskinfo?taskID=5827382

Note You need to log in before you can comment on or make changes to this bug.