Bug 992724 - perl-TAP-Formatter-JUnit: FTBFS in rawhide
perl-TAP-Formatter-JUnit: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: perl-TAP-Formatter-JUnit (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Berrange
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F20FTBFS
  Show dependency treegraph
 
Reported: 2013-08-05 01:57 EDT by Dennis Gilmore
Modified: 2013-08-12 08:37 EDT (History)
4 users (show)

See Also:
Fixed In Version: perl-TAP-Formatter-JUnit-0.09-7.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-12 08:37:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CPAN 81552 None None None Never

  None (edit)
Description Dennis Gilmore 2013-08-05 01:57:59 EDT
Your package perl-TAP-Formatter-JUnit failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=5742358

Build logs:
root.log: http://kojipkgs.fedoraproject.org/work/tasks/2358/5742358/root.log
build.log: http://kojipkgs.fedoraproject.org/work/tasks/2358/5742358/build.log
state.log: http://kojipkgs.fedoraproject.org/work/tasks/2358/5742358/state.log
NOTE: build logs are cleaned up after 1 week

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
Comment 1 Petr Pisar 2013-08-08 02:32:41 EDT
Tests fail due to randomized hashes.
Comment 2 Paul Howarth 2013-08-12 08:37:09 EDT
Strictly speaking, this is a test suite issue since the generated XML
remains valid, but some attributes are output in a different order than
expected by the test suite.

However, since I can't think of any simple way to make the tests more
forgiving of the order of the attributes in the XML, I've tweaked the
code to use Tie::IxHash to ensure that the generated XML has the
attributes in the same order as the tests expect them.

Build done: http://koji.fedoraproject.org/koji/taskinfo?taskID=5807770

Note You need to log in before you can comment on or make changes to this bug.