Bug 992807 - pngquant: FTBFS in rawhide
pngquant: FTBFS in rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: pngquant (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Björn 'besser82' Esser
Fedora Extras Quality Assurance
:
Depends On: 989991
Blocks: F20FTBFS
  Show dependency treegraph
 
Reported: 2013-08-05 02:36 EDT by Dennis Gilmore
Modified: 2013-09-23 14:13 EDT (History)
2 users (show)

See Also:
Fixed In Version: pngquant-2.0.0-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-02 07:12:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
tarball with patches to fix the FTBFS (2.86 KB, application/x-xz)
2013-08-23 02:14 EDT, Ralf Corsepius
no flags Details

  None (edit)
Description Dennis Gilmore 2013-08-05 02:36:17 EDT
Your package pngquant failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=5750638

Build logs:
root.log: http://kojipkgs.fedoraproject.org/work/tasks/638/5750638/root.log
build.log: http://kojipkgs.fedoraproject.org/work/tasks/638/5750638/build.log
state.log: http://kojipkgs.fedoraproject.org/work/tasks/638/5750638/state.log
NOTE: build logs are cleaned up after 1 week

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
Comment 1 Ralf Corsepius 2013-08-23 02:14:30 EDT
Created attachment 789461 [details]
tarball with patches to fix the FTBFS

This package suffers from several issues.

The immediate cause for the FTBFS type clashes/incompatibility of this package with libpng-1.6.

Also, this package doesn't honoring RPM_OPT_FLAGS (weird/broken Makefile/buildinfrastructure) and for reasons I do not understand is being built with hardend-cflags (Doesn't make any sense, IMO).

I intend to apply the attached patch, which is supposed to resolve all of the issues, later today.
Comment 2 Björn 'besser82' Esser 2013-08-23 04:52:23 EDT
Thanks for the patch Ralph!  Yesterday upstream released v2.0.0 which, besides other stuff, addresses the issues with libpng-1.6. see rhbz# 989991

So I'll update the package to v2.0.0 and take in all your proposed changes during today.
Comment 3 Ralf Corsepius 2013-08-23 05:42:09 EDT
(In reply to Björn "besser82" Esser from comment #2)
> Thanks for the patch Ralph!  Yesterday upstream released v2.0.0 which,
> besides other stuff, addresses the issues with libpng-1.6. see rhbz# 989991
Openly said, the *-libpng16.patch is a back port of what is in 2.0.0.

I don't know if the other patches will work with 2.0.0, because I noticed upstream has added a recursive subdir Makefile. I guess, I don't have to mention what I think of upstream's Makefiles ;)
Comment 4 Björn 'besser82' Esser 2013-08-23 05:56:25 EDT
I'm currently working on a patch for getting upstream's recursive Make-crap working ;)  Actually I offered upstream to autotoolify this and he agreed.  So I think next release of pngquant (2.0.1 or so) will be ship some autotools-based build-sys.  I'm not a friend of autotools, but it will be far better compared to now :)

You agree with me to build libimagequant a so-lib and ship it in a seperate subpkg "libimagequant"?  This is the intention about how to get it done with autotools, too.
Comment 5 Ralf Corsepius 2013-08-29 02:53:14 EDT
Ping? This FTBFS still persists.

I'd suggest, I'd apply my patch such that this bug can be closed.

I don't think this would be a problem to you, because this should not affect your autotool-/upgrading-activities and would take the pressure off from you.
Comment 6 Björn 'besser82' Esser 2013-08-29 03:23:07 EDT
pong!

I'm actually ready to push 2.0.0 (patched Makefiles) with building a so-lib (shipped in sub-pkg "libimgquant").  I just waited on some reply from you, Ralf, on comment #4.
Comment 7 Ralf Corsepius 2013-08-29 08:39:18 EDT
It's your package ... If you feel confident enough about, ... go ahead.
Comment 8 Fedora Update System 2013-09-02 06:58:34 EDT
pngquant-2.0.0-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/pngquant-2.0.0-1.fc19
Comment 9 Fedora Update System 2013-09-02 06:59:02 EDT
pngquant-2.0.0-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/pngquant-2.0.0-1.fc18
Comment 10 Fedora Update System 2013-09-02 06:59:29 EDT
pngquant-2.0.0-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/pngquant-2.0.0-1.el6
Comment 11 Fedora Update System 2013-09-02 07:00:07 EDT
pngquant-2.0.0-1.el5 has been submitted as an update for Fedora EPEL 5.
https://admin.fedoraproject.org/updates/pngquant-2.0.0-1.el5
Comment 12 Björn 'besser82' Esser 2013-09-02 07:12:42 EDT
(In reply to Ralf Corsepius from comment #5)
> Ping? This FTBFS still persists.
> 
> I'd suggest, I'd apply my patch such that this bug can be closed.

Previously mentioned updates have been successfuly build on F20 and rawhide, too.  This can be closed now.  :)
Comment 13 Fedora Update System 2013-09-02 19:29:40 EDT
pngquant-2.0.0-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Fedora Update System 2013-09-11 22:06:20 EDT
pngquant-2.0.0-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 15 Fedora Update System 2013-09-23 14:11:40 EDT
pngquant-2.0.0-1.el5 has been pushed to the Fedora EPEL 5 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2013-09-23 14:13:02 EDT
pngquant-2.0.0-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.