Bug 99294 - nameif doesn't allow one to assign names with MAC address
nameif doesn't allow one to assign names with MAC address
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: net-tools (Show other bugs)
9
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-17 00:36 EDT by Yusuf Goolamabbas
Modified: 2015-03-04 20:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-08-19 08:30:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Yusuf Goolamabbas 2003-07-17 00:36:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030706
Mozilla Firebird/0.6

Description of problem:
Hi, I am trying to hardwire my ethernet interfaces names with the use of nameif,
however when I create the appropiate /etc/mactab file for a machine containing 3
Intel EEpro cards
I get the following message

Cannot change name of eth2 to eth0: File Exists

I suspect it may be due to naming conflicts, I think this is better
described here

http://pcxperience.org/nameif/


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Create /etc/mactab
2. Introduce nameif in the networking script
   I used the technique described in Randy Dunlap's mini-howto

 
http://www.xenotime.net/linux/doc/network-interface-names.txt

Randy's changes were done on a Mandrake 9.0 installation

Actual Results:  Interface names not wired according to mac address

Additional info:

Possible bug fix described here


http://pcxperience.org/nameif/
Comment 1 Phil Knirsch 2003-08-19 08:30:21 EDT
Fixed in latest initscripts. Now you can use any kind of interface name (e.h.
ifcfg-foobar).

That should help.

Read ya, Phil
Comment 2 Yusuf Goolamabbas 2003-08-25 03:48:55 EDT
Phil, Any chance that is going to be queued for an errata release

Note You need to log in before you can comment on or make changes to this bug.