Bug 992946 - SELinux is preventing /usr/lib64/ejabberd/priv/bin/epam from read, open access on the file /usr/sbin/unix_chkpwd.
SELinux is preventing /usr/lib64/ejabberd/priv/bin/epam from read, open acces...
Status: CLOSED DUPLICATE of bug 992931
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:fbb631ce40045e2f13dc8087030...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-05 05:23 EDT by Samium Gromoff
Modified: 2013-08-05 10:31 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-05 10:31:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Samium Gromoff 2013-08-05 05:23:16 EDT
Description of problem:
I am trying to run ejabberd with PAM authentication, but SELinux shoots that down.

I have the following in my /etc/ejabberd/ejabberd.conf:
---- >8 ----
{auth_method, pam}.
{pam_service, "login"}.
---- 8< ----
SELinux is preventing /usr/lib64/ejabberd/priv/bin/epam from read, open access on the file /usr/sbin/unix_chkpwd.

*****  Plugin catchall (100. confidence) suggests  ***************************

If you believe that epam should be allowed read open access on the unix_chkpwd file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep epam /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:rabbitmq_beam_t:s0
Target Context                system_u:object_r:chkpwd_exec_t:s0
Target Objects                /usr/sbin/unix_chkpwd [ file ]
Source                        epam
Source Path                   /usr/lib64/ejabberd/priv/bin/epam
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           ejabberd-2.1.13-1.fc19.x86_64
Target RPM Packages           pam-1.1.6-12.fc19.x86_64
Policy RPM                    selinux-policy-3.12.1-69.fc19.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 3.9.5-301.fc19.x86_64 #1 SMP Tue
                              Jun 11 19:39:38 UTC 2013 x86_64 x86_64
Alert Count                   6
First Seen                    2013-08-05 12:44:06 MSK
Last Seen                     2013-08-05 13:18:43 MSK
Local ID                      91f6fff9-cf7e-4323-9b5b-5d2f029baddc

Raw Audit Messages
type=AVC msg=audit(1375694323.135:2084): avc:  denied  { read open } for  pid=16274 comm="epam" path="/usr/sbin/unix_chkpwd" dev="dm-3" ino=1598665 scontext=system_u:system_r:rabbitmq_beam_t:s0 tcontext=system_u:object_r:chkpwd_exec_t:s0 tclass=file


type=SYSCALL msg=audit(1375694323.135:2084): arch=x86_64 syscall=execve success=no exit=EACCES a0=7f4cfba6eb38 a1=7fff65c94f10 a2=7f4cfbc753a0 a3=7f4cfe8992e0 items=0 ppid=16249 pid=16274 auid=4294967295 uid=0 gid=989 euid=0 suid=0 fsuid=0 egid=989 sgid=989 fsgid=989 ses=4294967295 tty=(none) comm=epam exe=/usr/lib64/ejabberd/priv/bin/epam subj=system_u:system_r:rabbitmq_beam_t:s0 key=(null)

Hash: epam,rabbitmq_beam_t,chkpwd_exec_t,file,read,open

Additional info:
reporter:       libreport-2.1.6
hashmarkername: setroubleshoot
kernel:         3.9.5-301.fc19.x86_64
type:           libreport
Comment 1 Miroslav Grepl 2013-08-05 10:31:08 EDT

*** This bug has been marked as a duplicate of bug 992931 ***

Note You need to log in before you can comment on or make changes to this bug.