Fedora Account System
Red Hat Associate
Red Hat Customer
Description of problem: I am using apcupsd from Fedora EPEL on CentOS 6.4. The UPS is APC BackUPS ES 550 connected via USB cable. After a power failure (after battery goes out), users are prevented for logging in via SSH when power is restored (the system restarts automatically, via BIOS); message is "POWER FAILURE". This is probably because the existence of /etc/nologin A possible explanation is here http://comments.gmane.org/gmane.comp.sysutils.apcupsd.user/9304 Version-Release number of selected component (if applicable): apcupsd.x86_64 0:3.14.10-1.el6 How reproducible: Have not tried. Actual results: After a power failure (after battery goes out), users are prevented for logging in via SSH when power is restored (the system restarts automatically, via BIOS). Expected results: Users should be allowed to log in.
this is probably caused by fix for bug #788707 I'll look at it
new behavior: apcupsd will remove nologin file on startup if this file contains 'POWER FAILURE' (apcupsd puts it there)
apcupsd-3.14.10-2.el6 has been submitted as an update for Fedora EPEL 6. https://admin.fedoraproject.org/updates/apcupsd-3.14.10-2.el6
Package apcupsd-3.14.10-2.el6: * should fix your issue, * was pushed to the Fedora EPEL 6 testing repository, * should be available at your local mirror within two days. Update it with: # su -c 'yum update --enablerepo=epel-testing apcupsd-3.14.10-2.el6' as soon as you are able to. Please go to the following url: https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-11151/apcupsd-3.14.10-2.el6 then log in and leave karma (feedback).
apcupsd-3.14.10-2.el6 has been pushed to the Fedora EPEL 6 stable repository. If problems still persist, please make note of it in this bug report.