This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 992991 - apcupsd prevents users for loging in after a power failure
apcupsd prevents users for loging in after a power failure
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: apcupsd (Show other bugs)
el6
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Michal Hlavinka
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-05 07:04 EDT by Răzvan Sandu
Modified: 2013-09-16 13:45 EDT (History)
1 user (show)

See Also:
Fixed In Version: apcupsd-3.14.10-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-16 13:45:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Răzvan Sandu 2013-08-05 07:04:52 EDT
Description of problem:

I am using apcupsd from Fedora EPEL on CentOS 6.4. The UPS is APC BackUPS ES 550 connected via USB cable.

After a power failure (after battery goes out), users are prevented for logging in via SSH when power is restored (the system restarts automatically, via BIOS); message is "POWER FAILURE". This is probably because the existence of /etc/nologin

A possible explanation is here http://comments.gmane.org/gmane.comp.sysutils.apcupsd.user/9304


Version-Release number of selected component (if applicable):
apcupsd.x86_64 0:3.14.10-1.el6

How reproducible:
Have not tried.


Actual results:
After a power failure (after battery goes out), users are prevented for logging in via SSH when power is restored (the system restarts automatically, via BIOS).

Expected results:
Users should be allowed to log in.
Comment 1 Michal Hlavinka 2013-08-13 08:37:04 EDT
this is probably caused by fix for bug #788707
I'll look at it
Comment 2 Michal Hlavinka 2013-08-13 09:28:45 EDT
new behavior: apcupsd will remove nologin file on startup if this file contains 'POWER FAILURE' (apcupsd puts it there)
Comment 3 Fedora Update System 2013-08-13 09:57:52 EDT
apcupsd-3.14.10-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/apcupsd-3.14.10-2.el6
Comment 4 Fedora Update System 2013-08-16 13:03:31 EDT
Package apcupsd-3.14.10-2.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing apcupsd-3.14.10-2.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-11151/apcupsd-3.14.10-2.el6
then log in and leave karma (feedback).
Comment 5 Fedora Update System 2013-09-16 13:45:19 EDT
apcupsd-3.14.10-2.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.