Bug 993002 - [rhevm_33] - Installation - Cannot install Remote Setup (Based otopi engine setup )
[rhevm_33] - Installation - Cannot install Remote Setup (Based otopi engine s...
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.3.0
Unspecified Unspecified
unspecified Severity high
: ---
: ---
Assigned To: Moran Goldboim
Pavel Stehlik
integration
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-05 07:43 EDT by David Botzer
Modified: 2014-01-13 19:06 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-06 02:40:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
setuplog (1.36 MB, text/plain)
2013-08-05 07:43 EDT, David Botzer
no flags Details

  None (edit)
Description David Botzer 2013-08-05 07:43:24 EDT
Created attachment 782769 [details]
setuplog

Description of problem:
Engine - Installation - Cannot install Remote Setup

Version-Release number of selected component (if applicable):
3.3/is8

How reproducible:
always

Steps to Reproduce:
1.Install two clean RHEL64
2.Install On the first rhevm
3.Install on the second postgres
4.Run engine-setup on the first and select Remote setup

Actual results:
Setup fails, since the engine db password hadn't been generated yet, and there is no other password

Expected results:
Should create engine db on remote server
And Should complete installation successfully

Additional info:
I cant find the engine installation log !!!!

Database password:
[ ERROR ] Cannot connect to database: Cannot connect to database: FATAL:  password authentication failed for user "engine" FATAL:  password authentication failed for user "engine"
============================
/etc/ovirt-engine/engine.conf.d/ --> its empty

Workaround - Install rhevm on remote db server and run engine-setup
After it finishes run engine-cleanup
Comment 1 Itamar Heim 2013-08-06 02:40:36 EDT
I'm missing the part in which you manually created a user on the postgres host for the setup to use.

Note You need to log in before you can comment on or make changes to this bug.