Bug 99312 - RFE: always make and add a missing /usr/share/info/ directory in info package
Summary: RFE: always make and add a missing /usr/share/info/ directory in info package
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: texinfo   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2003-07-17 13:48 UTC by R P Herrold
Modified: 2007-04-18 16:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-10 16:11:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description R P Herrold 2003-07-17 13:48:54 UTC
Presently, doing an installation of info with the --excludedocs option will
cause subsequent errors from other packages (NOT installed with an
--excludedocs) which expect that the /usr/share/info/ exists without checking.

This is not an unreasonable expectation on the later package's part, so long as
the 'info' package was installed.

Please take this as my request that in the %install stanza of the .spec file,
that the following code be added:

[ ! -d $RPM_BUILD_ROOT%{prefix}/share/info/ ] && \
         mkdir -p $RPM_BUILD_ROOT%{prefix}/share/info/

and then below, add it to the %files manifest as a regularly required file (and
NOT an doco type file).

Comment 1 Ralph Siemsen 2003-07-17 13:58:21 UTC
Note this is a problem even if you install every package with --excludedocs,
since the %post scripts call install-info regardless.

Comment 2 Enrico Scholz 2003-07-18 19:51:16 UTC
And do not forget the %_netsharedpath macro...

See bug #51193 and
https://www.redhat.com/mailman/private/rpm-list/2003-May/msg00301.html also.

Comment 3 Tim Waugh 2003-07-28 16:44:32 UTC
/usr/share/info is provided by the filesystem package.

Comment 4 Ralph Siemsen 2003-07-28 20:22:51 UTC
The issue is not the existence of the directory /usr/share/info, but rather, the
failure of the program install-info to operate when /usr/share/info/dir is not
present, as will be the case when you install all packages with --excludedocs.

I can provide a log of the installation if you would like to see just how messed
up it gets.  Possible solution: if texinfo is installed --excludedocs then
replace install-info with a do-nothing script.


Comment 5 Tim Waugh 2004-12-10 16:11:54 UTC
I'm going to close this, since I don't see justification for installing all
packages with --excludedocs and then installing a documentation viewer.


Note You need to log in before you can comment on or make changes to this bug.