Bug 993148 - "Is shareable" option not updated when changing disk's allocation policy between Preallocated and Thin Provision.
"Is shareable" option not updated when changing disk's allocation policy betw...
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-webadmin-portal (Show other bugs)
3.3.0
Unspecified Unspecified
high Severity high
: ---
: 3.3.0
Assigned To: Sergey Gotliv
Leonid Natapov
storage
: Regression
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-05 12:48 EDT by Leonid Natapov
Modified: 2016-02-10 11:49 EST (History)
9 users (show)

See Also:
Fixed In Version: is9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-21 17:20:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
oVirt gerrit 17700 None None None Never

  None (edit)
Description Leonid Natapov 2013-08-05 12:48:36 EDT
Description of problem:

When creating new disk the default allocation policy is preallocated and user can check "is shareable" option. When switching to thin provision,the "is shareable" option turns to be greyed out. The problem is that when switching back to preallocated it stays greyed out. Basically once "is shareable" became greyed out it stays this way no matter what allocation policy you choose.  

Version-Release number of selected component (if applicable):


How reproducible:
100%


Steps to Reproduce:
1.Create new disk.
2.Notice that is shareable option not greyed out.
3.change allocation policy to thin provision. (notice that is shareable became greyed out)
4.change allocation policy to preallocated again.

is shareable stays greyed out.

Actual results:
When allocation policy is preallocated "is shareable" option checkable.
when allocation policy thin provision it's greyed out.

Expected results:


Additional info:
Comment 4 Leonid Natapov 2013-08-25 10:51:03 EDT
is11. fixed.
Comment 5 Itamar Heim 2014-01-21 17:20:02 EST
Closing - RHEV 3.3 Released
Comment 6 Itamar Heim 2014-01-21 17:25:51 EST
Closing - RHEV 3.3 Released

Note You need to log in before you can comment on or make changes to this bug.