Bug 993168 - zfs-fuse: FTBFS in rawhide
zfs-fuse: FTBFS in rawhide
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: zfs-fuse (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Gwyn Ciesla
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F20FTBFS
  Show dependency treegraph
 
Reported: 2013-08-05 12:50 EDT by Dennis Gilmore
Modified: 2013-08-13 16:06 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-13 16:06:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2013-08-05 12:50:58 EDT
Your package zfs-fuse failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=5761448

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
Comment 1 Petr Pisar 2013-08-06 09:05:37 EDT
gcc -o cmd/stat/common/timestamp.o -c -pipe -Wall -std=c99 -Wno-switch -Wno-unused -Wno-missing-braces -Wno-parentheses -Wno-uninitialized -fno-strict-aliasing -D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_REENTRANT -DTEXT_DOMAIN=\"zfs-fuse\" -O2 -Wp,-D_FORTIFY_SOURCE=2 -fstack-protector --param=ssp-buffer-size=4 -ggdb -DNDEBUG -O2 -g -pipe -Wall -Wp,-D_FORTIFY_SOURCE=2 -fexceptions -fstack-protector-strong --param=ssp-buffer-size=4 -grecord-gcc-switches -specs=/usr/lib/rpm/redhat/redhat-hardened-cc1 -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=hard -DLINUX_AIO -Ilib/libuutil/include -Ilib/libnvpair/include -Ilib/libumem/include -Ilib/libzfscommon/include -Ilib/libzfs/include -Ilib/libsolcompat/include -Ilib/libavl/include -Icmd/stat/common cmd/stat/common/timestamp.c
In file included from lib/libsolcompat/include/sys/types.h:30:0,
                 from /usr/include/stdlib.h:314,
                 from lib/libsolcompat/include/sys/time.h:33,
                 from cmd/stat/common/statcommon.h:38,
                 from cmd/stat/common/timestamp.c:26:
lib/libsolcompat/include/sys/isa_defs.h:544:2: error: #error "ISA not supported"
 #error "ISA not supported"
  ^
In file included from /usr/include/sys/types.h:222:0,
                 from lib/libsolcompat/include/sys/types.h:32,
                 from /usr/include/stdlib.h:314,
                 from lib/libsolcompat/include/sys/time.h:33,
                 from cmd/stat/common/statcommon.h:38,
                 from cmd/stat/common/timestamp.c:26:
lib/libsolcompat/include/sys/sysmacros.h:364:2: error: #error One of _BIT_FIELDS_LTOH or _BIT_FIELDS_HTOL must be defined
 #error One of _BIT_FIELDS_LTOH or _BIT_FIELDS_HTOL must be defined
  ^
scons: *** [cmd/stat/common/timestamp.o] Error 1
scons: building terminated because of errors.
error: Bad exit status from /var/tmp/rpm-tmp.HDjOxx (%build)
    Bad exit status from /var/tmp/rpm-tmp.HDjOxx (%build)

Bundled header files do not support ARM?
Comment 2 Gwyn Ciesla 2013-08-07 11:44:49 EDT
Looks like it.  And a patch from upstream is unlikely to be forthcoming, as upstream has apparently vanished.  What would be a good resource for patching this, setting the various defines to work properly on ARM?
Comment 3 Gwyn Ciesla 2013-08-13 16:06:08 EDT
Excluded ARM for now, filed 996728.

Note You need to log in before you can comment on or make changes to this bug.