Bug 993205 - Can't add a service
Can't add a service
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: firewalld (Show other bugs)
19
x86_64 Linux
urgent Severity high
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
: 993151 997184 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-05 13:05 EDT by Joshua Rosen
Modified: 2013-10-02 21:14 EDT (History)
12 users (show)

See Also:
Fixed In Version: firewalld-0.3.5-1.fc20
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-02 02:47:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joshua Rosen 2013-08-05 13:05:12 EDT
Description of problem: I can't add a service to the firewall. This seems to be new, I was able to do it a few weeks ago. I started firewall-config from a root shell, the traceback is below.


Version-Release number of selected component (if applicable):


How reproducible: 100%


Steps to Reproduce:
1. Select permanent configuration and Services
2. Click the + and name the service
3. Close the dialog

Actual results: No service is added


Expected results: New service should appear in the services list.


Additional info:
Traceback (most recent call last):
  File "/usr/bin/firewall-config", line 3168, in onServiceConfAddService
    self.add_edit_service(True)
  File "/usr/bin/firewall-config", line 3281, in add_edit_service
    settings = client.FirewallClientConfigServiceSettings()
AttributeError: 'module' object has no attribute 'FirewallClientConfigServiceSettings'
Comment 2 Jiri Popelka 2013-08-15 12:14:00 EDT
*** Bug 993151 has been marked as a duplicate of this bug. ***
Comment 3 Jiri Popelka 2013-08-16 12:09:55 EDT
*** Bug 997184 has been marked as a duplicate of this bug. ***
Comment 4 Lorenzo Pistone 2013-09-03 20:52:18 EDT
it is about time to release the fix, it prevents the usage of a core feature.
Comment 5 Elias Vanderstuyft 2013-09-07 04:51:44 EDT
Description of problem:
1. Go to 'Persistent Configuration'.
2. Go to 'Services'.
3. Left-bottom, click the '+' Add icon.
4. Create a new service with a valid not-yet existing name (normal procedure.)
Problem => New service is not added in the list.

Version-Release number of selected component:
firewall-config-0.3.4-1.fc19

Additional info:
reporter:       libreport-2.1.6
cmdline:        /usr/bin/python /usr/bin/firewall-config
executable:     /usr/bin/firewall-config
kernel:         3.10.10-200.fc19.x86_64
runlevel:       N 5
type:           Python
uid:            1000

Truncated backtrace:
firewall-config:3281:add_edit_service:AttributeError: 'module' object has no attribute 'FirewallClientConfigServiceSettings'

Traceback (most recent call last):
  File "/usr/bin/firewall-config", line 3168, in onServiceConfAddService
    self.add_edit_service(True)
  File "/usr/bin/firewall-config", line 3281, in add_edit_service
    settings = client.FirewallClientConfigServiceSettings()
AttributeError: 'module' object has no attribute 'FirewallClientConfigServiceSettings'

Local variables in innermost frame:
old_short: None
short: ''
name: 'revolt-client-server'
buffer: <TextBuffer object at 0x2a8f7d0 (GtkTextBuffer at 0x2529990)>
add: True
self: <__main__.FirewallConfig object at 0x21afa10>
old_version: None
old_target: None
builtin: False
version: ''
result: 1
old_name: None
old_desc: None
desc: ''
Comment 6 Heiko Adams 2013-09-14 17:49:08 EDT
When will there be updated packages to fix this annoying bug?
Comment 7 Joshua Rosen 2013-09-29 19:00:27 EDT
Is anyone working on this? I submitted this bug at the start of Aug, it's now the end of September and it hasn't been addressed. This is a serious bug, it makes using the firewall impractical.
Comment 8 Chen-Pang He 2013-09-30 07:27:20 EDT
I do not have a fix, but you can edit configs by hand.  User-modified configs are in /etc/firewalld/, default ones in /lib/firewalld/.

### Add/modify a service ###

You can create a firewalld xml in /etc/firewalld/services/.  For example, you create /etc/firewalld/services/bt.xml whose content is

<?xml version="1.0" encoding="utf-8"?>
<service>
  <short>BitTorrent</short>
  <description>BitTorrent rocks!</description>
  <port protocol="tcp" port="6881"/>
  <port protocol="udp" port="7881"/>
</service>

Then you have added a service called "bt" which requires 6881/tcp and 7881/udp.  The <short> and <description> tags are optional.  They are reminders for humans.

Reload firewalld (either by GUI or by "systemctl reload firewalld") to have it take effect.  Your config overrides the one in /lib/firewalld/services/ if any.

### Add/modify a zone ###

You can also create /etc/firewalld/zones/www.xml whose content is

<?xml version="1.0" encoding="utf-8"?>
<zone>
  <short>Web server</short>
  <description>For computers working as webpage servers.</description>
  <service name="http"/>
  <service name="ssh"/>
  <service name="https"/>
</zone>

Then you have added a zone called "www" where only ports for these three services are open.  Reload firewalld to take effect.  Again, your config overrides the one in /lib/firewalld/zones/ if any.
Comment 9 Fedora Update System 2013-09-30 08:35:38 EDT
firewalld-0.3.5-1.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/firewalld-0.3.5-1.fc20
Comment 10 Fedora Update System 2013-09-30 08:38:51 EDT
firewalld-0.3.5-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/firewalld-0.3.5-1.fc19
Comment 11 Stephen Tweedie 2013-09-30 09:06:23 EDT
(In reply to Fedora Update System from comment #10)
> firewalld-0.3.5-1.fc19 has been submitted as an update for Fedora 19.
> https://admin.fedoraproject.org/updates/firewalld-0.3.5-1.fc19

Tested and karma left --- fixes the issue for me, new services can be set up and are visible in iptables after a config reload.

Thanks!
Comment 12 Fedora Update System 2013-09-30 22:01:51 EDT
Package firewalld-0.3.5-1.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing firewalld-0.3.5-1.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-17984/firewalld-0.3.5-1.fc20
then log in and leave karma (feedback).
Comment 13 Joshua Rosen 2013-09-30 22:21:44 EDT
Is it going to be pushed to F19 or is the fix for F20 only?
Comment 14 Jiri Popelka 2013-10-01 03:47:21 EDT
(In reply to Joshua Rosen from comment #13)
> Is it going to be pushed to F19 or is the fix for F20 only?

See comment #10.
Comment 15 Joshua Rosen 2013-10-01 04:48:35 EDT
It's not there yet, I'll wait for the update and let you know if it works for me.
Comment 16 Fedora Update System 2013-10-02 02:47:36 EDT
firewalld-0.3.5-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 17 Joshua Rosen 2013-10-02 08:46:11 EDT
It's not there in either the stable or testing repos
Comment 18 Pedro Francisco 2013-10-02 08:53:28 EDT
Usually that would be because the mirrors are still syncing.
If it doesn't appear in the next (12?) hours, ask here again.

If you don't say anything else, we will assume all has been fixed, available and working properly.
Comment 19 Fedora Update System 2013-10-02 21:14:53 EDT
firewalld-0.3.5-1.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.