Bug 993245 - scl-utils: FTBFS in rawhide
scl-utils: FTBFS in rawhide
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: scl-utils (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Zeleny
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F20FTBFS
  Show dependency treegraph
 
Reported: 2013-08-05 13:11 EDT by Dennis Gilmore
Modified: 2013-09-03 18:29 EDT (History)
3 users (show)

See Also:
Fixed In Version: scl-utils-20130529-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-03 18:29:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2013-08-05 13:11:31 EDT
Your package scl-utils failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=5769316

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
Comment 1 Ralf Corsepius 2013-08-25 02:36:53 EDT
This package doesn't build because it treats a symlink as directory:
...
error: Not a directory: /builddir/build/BUILDROOT/scl-utils-20130529-1.fc19.x86_64/etc/scl/conf

A fix would be this:

diff --git a/scl-utils.spec b/scl-utils.spec
index f2fa7fa..e0523d4 100644
--- a/scl-utils.spec
+++ b/scl-utils.spec
@@ -50,7 +50,8 @@ rm -rf %buildroot
 %files
 %defattr(-,root,root,-)
 %dir /opt/rh
-%dir %{_sysconfdir}/scl/conf
+%dir %{_sysconfdir}/scl
+%{_sysconfdir}/scl/conf
 %dir %{_sysconfdir}/scl/prefixes
 %{_bindir}/scl
 %{_bindir}/scl_enabled

I am not going to apply this fix, because this bug also is present in f19, which lets me think this package is unmaintained and should be orphaned.'
Comment 2 Jan Zeleny 2013-08-26 03:19:11 EDT
The package is maintained, I just don't have that much time for it, sorry for that. Thank you for the patch, I will apply the fix in all relevant branches.
Comment 3 Ralf Corsepius 2013-08-26 03:33:40 EDT
(In reply to Jan Zeleny from comment #2)
> The package is maintained, I just don't have that much time for it, sorry
> for that. Thank you for the patch, I will apply the fix in all relevant
> branches.

11 open bugs, and the fact this package FTBFSes on f19, f20 and rawhide speak a different language:
https://admin.fedoraproject.org/pkgdb/acls/bugs/scl-utils?_csrf_token=ad569c83a19879e9a2e32aff4aca5ad23ca5b666


Besides this, the fact this package adds /opt/rh alone would be sufficient reason to demand this package to be removed from Fedora.
Comment 4 Jan Zeleny 2013-08-26 03:51:03 EDT
(In reply to Ralf Corsepius from comment #3)
> (In reply to Jan Zeleny from comment #2)
> > The package is maintained, I just don't have that much time for it, sorry
> > for that. Thank you for the patch, I will apply the fix in all relevant
> > branches.
> 
> 11 open bugs, and the fact this package FTBFSes on f19, f20 and rawhide
> speak a different language:
> https://admin.fedoraproject.org/pkgdb/acls/bugs/scl-
> utils?_csrf_token=ad569c83a19879e9a2e32aff4aca5ad23ca5b666

Have you seen the number of bugs for components like yum? In this case we have 3 RFEs, 1 that I consider deferred and this one (fixed in f19, f20 and rawhide), ending with 6 bugs - not that bad I'd say.

> Besides this, the fact this package adds /opt/rh alone would be sufficient
> reason to demand this package to be removed from Fedora.

Please don't take this personally but you obviously don't know the background here. Adding the directory is actually the main purpose of this package.
Comment 5 Fedora Update System 2013-08-26 03:57:40 EDT
scl-utils-20130529-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/scl-utils-20130529-2.fc19
Comment 6 Fedora Update System 2013-08-26 18:26:57 EDT
Package scl-utils-20130529-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing scl-utils-20130529-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15311/scl-utils-20130529-2.fc19
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-09-03 18:29:05 EDT
scl-utils-20130529-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.