Bug 993248 - rhc scale-cartridge hangs indefinitely when scaling up
rhc scale-cartridge hangs indefinitely when scaling up
Status: CLOSED DUPLICATE of bug 994130
Product: OpenShift Online
Classification: Red Hat
Component: Command Line Interface (Show other bugs)
2.x
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Clayton Coleman
libra bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-05 13:21 EDT by Ben Browning
Modified: 2015-05-14 22:24 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-19 16:10:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ben Browning 2013-08-05 13:21:01 EDT
Description of problem:

Every time I manually scale up my application via a command like'rhc scale-cartridge jbossas-7 --min 2 --max 2' the command hangs forever. The new gear does get created but the command never returns so I have to CTRL+C it. It doesn't matter if I'm scaling from 1 to 2 gears, 2 to 3, or 1 to 3 - it hangs every time.
Comment 1 Wei Sun 2013-08-05 22:36:44 EDT
Test this bug on devenv_stage_438,and rhc is rhc 1.12.4,but can not reproduce this bug.

Result:
[wsun@dhcp-8-229 ~]$ rhc scale-cartridge jbossas-7 -a jbs --min 2 --max 2 -p x
This operation will run until the application is at the minimum scale and may take several minutes.
Setting scale range for jbossas-7 ... done

jbossas-7 (JBoss Application Server 7)
--------------------------------------
  Scaling: x2 (minimum: 2, maximum: 2) on small gears
[wsun@dhcp-8-229 ~]$ rhc scale-cartridge jbossas-7 -a jbs --min 2 --max 3 -p x
This operation will run until the application is at the minimum scale and may take several minutes.
Setting scale range for jbossas-7 ... done

jbossas-7 (JBoss Application Server 7)
--------------------------------------
  Scaling: x2 (minimum: 2, maximum: 3) on small gears
Comment 2 Clayton Coleman 2013-08-06 10:30:54 EDT
Ben, can you describe how long you waited?  Scale ups of JBoss can take several minutes - can you run with "-d" so we have some more info about what's going on?
Comment 3 Ben Browning 2013-08-06 10:53:07 EDT
I'm fairly certain that I've let it sit for a couple of hours before. I know I've let it sit for at least 30 minutes. This isn't intermittent - it happens every time. I'm currently testing some other clustering-related issues but as soon as I can scale the cluster down then back up again I'll get the requested output.
Comment 4 Ben Browning 2013-08-06 11:55:40 EDT
Here's the request output. At this point I've let the command sit for 20 minutes and it's still hung, even though both gears are up, have my application deployed, and are handling web requests.

bbrowning@f19 ~/tmp/tb3cluster]$ rhc scale-cartridge jbossas-7 --min 1 --max 1
This operation will run until the application is at the minimum scale and may take several minutes.
Setting scale range for jbossas-7 ... done

jbossas-7 (JBoss Application Server 7)
--------------------------------------
  Scaling: x1 (minimum: 1, maximum: 1) on small gears
[bbrowning@f19 ~/tmp/tb3cluster]$ rhc scale-cartridge jbossas-7 --min 2 --max 2 -d
DEBUG: Using config file /home/bbrowning/.openshift/express.conf
DEBUG: Authenticating with RHC::Auth::Token
DEBUG: Connecting to https://openshift.redhat.com/broker/rest/api
DEBUG: Getting all domains
DEBUG: Client supports API versions 1.1, 1.2, 1.3, 1.4, 1.5
DEBUG: Using token authentication
DEBUG: Request GET https://openshift.redhat.com/broker/rest/api
DEBUG:    code 200  334 ms
DEBUG: Server supports API versions 1.0, 1.1, 1.2, 1.3, 1.4, 1.5
DEBUG: Using token authentication
DEBUG: Request GET https://openshift.redhat.com/broker/rest/domains
DEBUG:    code 200   83 ms
DEBUG: Getting app context
DEBUG: Running git config --get rhc.app-name
DEBUG: UUID = 'tb3cluster'
DEBUG: Getting all domains
DEBUG: Getting app context
DEBUG: Running git config --get rhc.app-name
DEBUG: UUID = 'tb3cluster'
DEBUG: Using token authentication
DEBUG: Request GET https://openshift.redhat.com/broker/rest/domains/bbrowning/applications/tb3cluster?include=cartridges
DEBUG:    code 200  217 ms
This operation will run until the application is at the minimum scale and may take several minutes.
Setting scale range for jbossas-7 ... DEBUG: Setting scales = scales_from: 2 scales_to: 2
DEBUG: Using token authentication
DEBUG: Request PUT https://openshift.redhat.com/broker/rest/domains/bbrowning/applications/tb3cluster/cartridges/jbossas-7
Comment 5 Mrunal Patel 2013-08-19 16:10:44 EDT
This looks like it is related to 994130.

*** This bug has been marked as a duplicate of bug 994130 ***

Note You need to log in before you can comment on or make changes to this bug.