Bug 993385 - stratagus: FTBFS in rawhide
stratagus: FTBFS in rawhide
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: stratagus (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Filipe Rosset
Fedora Extras Quality Assurance
:
: 1107379 (view as bug list)
Depends On: 1094103
Blocks: F21FTBFS
  Show dependency treegraph
 
Reported: 2013-08-05 16:33 EDT by Dennis Gilmore
Modified: 2014-06-16 18:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-06-16 13:45:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dennis Gilmore 2013-08-05 16:33:09 EDT
Your package stratagus failed to build from source in current rawhide.

http://koji.fedoraproject.org/koji/taskinfo?taskID=5773796

For details on mass rebuild see https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
Comment 1 Fedora End Of Life 2013-09-16 12:02:28 EDT
This bug appears to have been reported against 'rawhide' during the Fedora 20 development cycle.
Changing version to '20'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/BugZappers/HouseKeeping/Fedora20
Comment 2 Bruno Wolff III 2013-11-11 09:37:23 EST
If I can get this building again, I'll adopt it.
Comment 3 Bruno Wolff III 2013-12-01 12:16:30 EST
2.2.7 helps with some of the issues, but the change to cmake invalidates some of the other patches. guichan is still bundled and that would need to still have a patch to fix. There is also a bug for the metaserver build, which is only done if sqllite is installed. I am not sure if that is something we want built now (meaning we need a patch for the bug) or if we should just not include sqllite. (For the latter case a patch to disable this so that fedpkg local works would be nice but isn't required.)
I don't know enough about using to stratagus to be able to properly test it and don't really have time to learn right now. So I think unless someone else steps up as the primary maintainer, we should retire this in f21.
Comment 4 Fedora Admin XMLRPC Client 2014-02-20 22:13:20 EST
This package has changed ownership in the Fedora Package Database.  Reassigning to the new owner of this component.
Comment 5 Filipe Rosset 2014-03-18 19:57:43 EDT
Hi guys, sorry to bother you.

I'm working to fix stratagus 2.2.7 on rawhide, but there are something strange in linking steps that I'm not aware, maybe you've any hint?

Looks like all gcc build is done but then the linking part is broken, not sure if it's by tolua++(only compatible w/ lua5.1), compat-lua(5.1), or something trying to linking against lua5.2?
I'm a bit confused about this build.

http://fpaste.org/86554/
Comment 6 Filipe Rosset 2014-06-11 00:15:17 EDT
It's almost done, needs a fix in tolua++ to build properly in x86 (arm + x86_64 are fine).
Comment 7 Filipe Rosset 2014-06-11 00:16:24 EDT
*** Bug 1107379 has been marked as a duplicate of this bug. ***
Comment 8 Hans de Goede 2014-06-16 13:45:25 EDT
I've just done a successful build of stratagus with a fixed tolua++, closing.

Note You need to log in before you can comment on or make changes to this bug.