Bug 99339 - [RFE] Request for a Gnome 2 native PDF viewer
[RFE] Request for a Gnome 2 native PDF viewer
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: distribution (Show other bugs)
9
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
: FutureFeature
: 77866 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-17 16:46 EDT by Michael Lee Yohe
Modified: 2014-03-16 22:37 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-01 15:34:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Red Hat 9 compatible source RPM for libpaper (183.72 KB, application/octet-stream)
2003-07-17 16:46 EDT, Michael Lee Yohe
no flags Details
Red Hat Linux 9 compatible SRPM for Gpdf (684.24 KB, application/octet-stream)
2003-07-17 17:06 EDT, Michael Lee Yohe
no flags Details

  None (edit)
Description Michael Lee Yohe 2003-07-17 16:46:05 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030530 Galeon/1.3.5

Description of problem:
As per Jonathon Bedford's comments in Bug 88680, it would appear that the GGV
application is about to get its PDF support castrated.  Although xpdf is still
available, it's written for X and has an interface that dates back to the time
where Gremlins were popular in every driveway.

Since we have such wonderful helper utilities with the Gnome 2 desktop suite,
would it not make sense to include something that meshes well with Gnome 2? 

GPdf is a current Gnome 2 project (http://www.inf.tu-dresden.de/~mk793652/gpdf/)
that is a Gnome 2 front-end to xpdf, and also uses Gnome 2's print preview
helper (to cohesively integrate with the desktop environment).

GPdf requires libpaper (which assists calculating for paper size).  I will
attach two Red Hat 9 compatible SRPMS to this bug (one for libpaper and the
other for gpdf).



Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. see description


Actual Results:  see description


Expected Results:  see description


Additional info:
Comment 1 Michael Lee Yohe 2003-07-17 16:46:58 EDT
Created attachment 92987 [details]
Red Hat 9 compatible source RPM for libpaper

This is one of the dependencies for Gpdf.
Comment 2 Michael Lee Yohe 2003-07-17 17:06:09 EDT
Created attachment 92989 [details]
Red Hat Linux 9 compatible SRPM for Gpdf

This is the latest version of Gpdf.  It will need to be reworked (icons on the
Gnome menu), but overall - excellent for testing purposes.
Comment 3 Bill Nottingham 2003-07-23 11:54:17 EDT
Someone tried gpdf here, and discovered it can't print. If it can't do that,
there's no way it's going in...
Comment 4 Remi Cohen-Scali 2003-08-04 10:03:40 EDT
Hy
I'am a gnome developer working on GPdf. I have a print feature in a dev branch
of gpdf (gpdf-outlines). 
I have a few questions in order to evaluate what could be done to fullfil your
request.
1) What is your due date for this problem to be solved
2) Have you got resources for backporting print feature (1 day of work)

Regards
Comment 5 Havoc Pennington 2003-08-04 10:55:13 EDT
Honestly it's probably past the date, but no worries, we can get it in next time.
Comment 6 Remi Cohen-Scali 2003-08-04 17:21:45 EDT
So be it ;-)
Comment 7 Michael Lee Yohe 2003-08-05 09:42:56 EDT
I believe it should still be an active Rawhide package.  It's nice to see
developer support for Gpdf on board.
Comment 8 Michael Lee Yohe 2003-08-08 13:44:32 EDT
*** Bug 77866 has been marked as a duplicate of this bug. ***
Comment 9 Michael Lee Yohe 2003-10-31 17:36:40 EST
Hi, Remi - I noticed that GPdf has been added to Rawhide and is to be
supported for Fedora Core.  I am running GPdf from Rawhide and but
don't see any print features.  Is Red Hat up2date?
Comment 10 Bill Nottingham 2005-03-01 15:34:06 EST
Currently in development we have evince, previously we had both gpdf and ggv.
Closing.

Note You need to log in before you can comment on or make changes to this bug.