Bug 993397 - missing mate-keyring pam authorization for MATE desktop
Summary: missing mate-keyring pam authorization for MATE desktop
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: sddm
Version: rawhide
Hardware: All
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Martin Bříza
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2013-08-05 20:34 UTC by Wolfgang Ulbrich
Modified: 2013-09-12 01:59 UTC (History)
6 users (show)

Fixed In Version: sddm-0.2.0-0.4.20130821gite707e229.fc18
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-09-06 03:59:45 UTC
Type: Bug


Attachments (Terms of Use)

Description Wolfgang Ulbrich 2013-08-05 20:34:14 UTC
Hi,
this is more a feature request than a issue report.
Currently i'm thinking about to use sddm for mate desktop in f20 as mate maintainer.
Adding support for mate-keyring is very easy.
Simply change the pam file to

#%PAM-1.0
auth     [success=done ignore=ignore default=bad] pam_selinux_permit.so
auth       required    pam_env.so
auth       substack    system-auth
-auth       optional    pam_gnome_keyring.so
-auth       optional    pam_mate_keyring.so
auth       include     postlogin
account    required    pam_nologin.so
account    include     system-auth
password   include     system-auth
session    required    pam_selinux.so close
session    required    pam_loginuid.so
session    optional    pam_console.so
-session    optional    pam_ck_connector.so
session    required    pam_selinux.so open
session    optional    pam_keyinit.so force revoke
session    required    pam_namespace.so
session    include     system-auth
-session    optional    pam_gnome_keyring.so auto_start
-session    optional    pam_mate_keyring.so auto_start
session    include     postlogin

It would be very nice to do this for rawhide/f19/f18

Thank you

Wolfgang

Comment 1 Martin Bříza 2013-08-06 12:20:57 UTC
Hello Wolfgang,
thanks for your report. I pushed the change (commit 195b5eb95c) to all three repositories.
It will be included in the next update some time this week.

Comment 2 Wolfgang Ulbrich 2013-08-06 12:30:43 UTC
Hi Martin,
thank you. i've a off topic question.
If i use sddm, the .xseessionerror log won't be updated anymore, means no new information if seesion is started is written.
Is this a known issue?
Tested with rawhide and f18.

Comment 3 Martin Bříza 2013-08-06 12:35:28 UTC
No, this exactly isn't known to me. I know there are some issues with the initial environment settings and session configuration. I haven't really investigated it in-depth so far unfortunately.
Could you please open an other bug with this? Please include as much information as you can.
Thank you.

Comment 4 Fedora Update System 2013-08-21 11:52:34 UTC
sddm-0.2.0-0.130821.git.e707e229.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/sddm-0.2.0-0.130821.git.e707e229.fc18

Comment 5 Fedora Update System 2013-08-21 11:52:53 UTC
sddm-0.2.0-0.130821.git.e707e229.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/sddm-0.2.0-0.130821.git.e707e229.fc19

Comment 6 Fedora Update System 2013-08-22 00:45:07 UTC
Package sddm-0.2.0-0.130821.git.e707e229.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing sddm-0.2.0-0.130821.git.e707e229.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15099/sddm-0.2.0-0.130821.git.e707e229.fc18
then log in and leave karma (feedback).

Comment 7 Fedora Update System 2013-08-22 09:19:01 UTC
sddm-0.2.0-0.1.20130821gite707e229.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/sddm-0.2.0-0.1.20130821gite707e229.fc18

Comment 8 Fedora Update System 2013-08-22 09:20:54 UTC
sddm-0.2.0-0.1.20130821gite707e229.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/sddm-0.2.0-0.1.20130821gite707e229.fc19

Comment 9 Martin Bříza 2013-08-22 09:23:53 UTC
Hi Wolfgang,
I just repushed the package, please note you'll have to run yum distro-sync or yum downgrade to get this version.
Sorry for the confusion.

Comment 10 Wolfgang Ulbrich 2013-08-22 10:25:27 UTC
Hi Martin,
np, but the issue is that the old version is in f20 stable and rawhide (f20 is branched today)
Why not using sddm-0.2.0-0.2.20130821gite707e229.fc19 to get higher version (0.2 instead 0.1 before date). This should update the old version

Comment 11 Martin Bříza 2013-08-22 10:39:31 UTC
It does not, unfortunately. The number would have to be higher than 130821 which would be very confusing...
It is an issue we there is a "newer" version in fc20 and fc21 though. This will be resolved either by users manually installing this (I doubt the wrong version is widespread) and the further packages or after release of the actual sddm-0.2.0 which will make the package's release just 1 instead of 0 and checkout information, thus updating it automatically.

Comment 12 Kevin Kofler 2013-08-22 22:45:52 UTC
I untagged the f20 and f21 builds in Koji yesterday, as soon as I noticed the wrong versioning, so I'm not sure they even entered a compose (I hope not). In any case, today's compose for f20 has the correctly-versioned build, Rawhide the old 0.1.5 build altogether (the new one was built and should be in tomorrow's compose).

Comment 13 Fedora Update System 2013-09-06 03:59:45 UTC
sddm-0.2.0-0.4.20130821gite707e229.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 14 Fedora Update System 2013-09-06 05:19:10 UTC
sddm-0.2.0-0.4.20130821gite707e229.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 15 Fedora Update System 2013-09-12 01:59:36 UTC
sddm-0.2.0-0.4.20130821gite707e229.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.