Bug 9934 - Network stops responding under heavy loads
Network stops responding under heavy loads
Status: CLOSED CURRENTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
6.2
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Nalin Dahyabhai
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-03-03 12:45 EST by Michael J. Kidd
Modified: 2008-05-01 11:37 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-12-15 21:55:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael J. Kidd 2000-03-03 12:45:13 EST
Using Toshiba Satellite 2595CDS w/ 3COM Megahertz (PCMCIA) 10/100 LAN +56K
Modem (Model 3CCFEM556B)  Under moderate to heavy transfer rates (
Operating on a 10bit Network Rates > 300k/sec ) All network traffic
stops.. No ping will go through at all.  If the interface is ifdown then
ifup again.. network flow resumes.  This is true for FTP and Samba Files
transfers.
Comment 1 alambie 2000-04-03 19:39:59 EDT
I saw this on an eepro100 card on a desktop machine.  It wasn't under
particularly heavy load, although it may have had a burst of activity.  Bouncing
the interface fixed it.
Comment 2 doane 2000-05-08 15:25:59 EDT
I am experiencing similar problems.

I upgraded from 6.1 to 6.2, and now experience intermittent network "freezes".
In my case, the network seems to return to proper function after a period of
time that is often long enough the X apps on the box to time out.  I have not
tried restarting the interface.

I am also using the eepro100 card.
Comment 3 doane 2000-05-09 04:32:59 EDT
I have swapped my eepro100 card for a tulip, and now all seems well (after
several hours of network interaction with the box in question).  It seems that
the change in the eepro100 driver from 6.1 to 6.2 has caused my card, and
presumably others, to malfunction.
Comment 4 gerd.schelbert 2000-05-19 03:33:59 EDT
This problem also occurs on a DELL Dimension XPS R350 with 3com 905b
LAN-Adapter. System worked fine before with several SUSE-Revisions and also with
a RedHat 6.0.

So it seems that it is no single driver-problem.
Comment 5 Guðmundur D. H. 2000-05-25 18:34:59 EDT
I have experinced this also. That was on RH 6.0, using Tulip, under heavy load;
the card seams to stop, to get it back up i have to ifconfig it down and up
again. Strange..
Comment 6 Diablo 2000-10-12 20:06:06 EDT
Similar thing happens using the eepro driver for the Intel
EtherExpress PRO/10 ISA.  Using Kernel 2.2.14-5.0 (stock from
RH6.2), the NIC works just fine.  After upgrade to latest
Kernel 2.2.16-3 it gives the problems.

Also look at Bug #19006
Comment 7 Alan Cox 2002-12-15 21:55:03 EST
eepro one was known (and fixed next errata)
others seem to have gone away with the newer networking driver code - especially
tulip clone problems

Note You need to log in before you can comment on or make changes to this bug.