Bug 993400 - [abrt] firewall-config-0.2.12-6.fc18: firewall-config:941:onChangeZone:TypeError: 'NoneType' object has no attribute '__getitem__'
[abrt] firewall-config-0.2.12-6.fc18: firewall-config:941:onChangeZone:TypeEr...
Status: CLOSED DUPLICATE of bug 995760
Product: Fedora
Classification: Fedora
Component: firewalld (Show other bugs)
18
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
abrt_hash:d720d41d15d20095d01992b516d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-05 16:36 EDT by Maurizio
Modified: 2013-08-15 12:02 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Known Issue
Doc Text:
Cause: HW Consequence:letter D Workaround (if any): Mac Adress spooff Result: Server is disagree
Story Points: ---
Clone Of:
Environment:
server seems to ignore abrt oops
Last Closed: 2013-08-15 12:02:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (590 bytes, text/plain)
2013-08-05 16:36 EDT, Maurizio
no flags Details
File: environ (1.51 KB, text/plain)
2013-08-05 16:36 EDT, Maurizio
no flags Details

  None (edit)
Description Maurizio 2013-08-05 16:36:51 EDT
Version-Release number of selected component:
firewall-config-0.2.12-6.fc18

Additional info:
reporter:       libreport-2.1.5
cmdline:        /usr/bin/python /usr/bin/firewall-config
core_backtrace: d393fa85d6b8b8c27d75abe0345dccc993749b47 0x3ad onChangeZone /usr/bin/firewall-config -
executable:     /usr/bin/firewall-config
kernel:         3.9.11-200.fc18.x86_64
runlevel:       N 5
uid:            1000

Truncated backtrace:
firewall-config:941:onChangeZone:TypeError: 'NoneType' object has no attribute '__getitem__'

Traceback (most recent call last):
  File "/usr/bin/firewall-config", line 941, in onChangeZone
    _services = services[:]
TypeError: 'NoneType' object has no attribute '__getitem__'

Local variables in innermost frame:
masquerade: False
self: <__main__.FirewallConfig object at 0x21f7a10>
args: (<TreeSelection object at 0x25785a0 (GtkTreeSelection at 0x23a74f0)>,)
ports: []
builtin: False
icmpblocks: []
active_zone: 'public'
defaults: False
services: None
immutable: False
forward_ports: []
Comment 1 Maurizio 2013-08-05 16:36:54 EDT
Created attachment 783008 [details]
File: backtrace
Comment 2 Maurizio 2013-08-05 16:36:57 EDT
Created attachment 783009 [details]
File: environ
Comment 3 Jiri Popelka 2013-08-15 12:02:32 EDT

*** This bug has been marked as a duplicate of bug 995760 ***

Note You need to log in before you can comment on or make changes to this bug.