Bug 993406 - update python-pyquery from 0.6.1 to 1.2.4
update python-pyquery from 0.6.1 to 1.2.4
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: python-pyquery (Show other bugs)
el6
All Linux
unspecified Severity high
: ---
: ---
Assigned To: Matěj Cepl
Fedora Extras Quality Assurance
https://admin.fedoraproject.org/updat...
:
Depends On: 875213 980856
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-05 16:52 EDT by Matěj Cepl
Modified: 2013-12-21 13:53 EST (History)
5 users (show)

See Also:
Fixed In Version: python-pyquery-1.2.4-1.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 980856
Environment:
Last Closed: 2013-12-21 13:53:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matěj Cepl 2013-08-05 16:52:39 EDT
Building of python-pyquery on EL-6 will be more complicated as we don’t have python-cssselect here.

+++ This bug was initially created as a clone of Bug #980856 +++

Description of problem:

python-pyquery 0.6.1 is more than two years old.

New code examples don't work with python-pyquery 0.6.1.

Please update the package to python-pyquery 1.2.4.

...

I have attached an updated SPEC file to fix this problem.

--- Additional comment from Matěj Cepl on 2013-08-05 19:10:24 CEST ---
Comment 1 Matěj Cepl 2013-08-05 17:11:28 EDT
Actually more than on bug 875213, it depends now only on the moment when https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-10996/python-cssselect-0.8-1.el6 will be in stable.
Comment 2 Eric Smith 2013-08-05 17:22:40 EDT
python-cssselect-0.8-1.el6 will likely pushed to stable on August 10 or 11.  If that's not soon enough, get people to test it and leave karma.

On the other hand, couldn't python-pyquery use the cssselect from lxml, which is already in el6?
Comment 3 Matěj Cepl 2013-08-06 03:59:34 EDT
(In reply to Eric Smith from comment #2)
> python-cssselect-0.8-1.el6 will likely pushed to stable on August 10 or 11. 
> If that's not soon enough, get people to test it and leave karma.

Surely, it is OK, there is no rush. BTW, I left karma, but you left the original +3/-3 karma borders, which is IMHO way too much for EPEL packages. I usually switch karma borders to +1/-1 to get at least some effects from the voluntary testing.

> On the other hand, couldn't python-pyquery use the cssselect from lxml,
> which is already in el6?

What are your thoughts on bug 968831 ?
Comment 4 Eric Smith 2013-08-06 11:45:51 EDT
I think 968831 is because cssselect was formerly a component of lxml, but has more recently been split into a separate upstream package.  However, it appears that the version of lxml in EL6 still contains a cssselect.  I was actually somewhat reluctant to push a cssselect package for EPEL6 for that reason, but decided that it shouldn't hurt anything.
Comment 5 Fedora Update System 2013-09-27 10:37:00 EDT
python-pyquery-1.2.4-1.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/python-pyquery-1.2.4-1.el6
Comment 6 Fedora Update System 2013-09-27 14:42:17 EDT
Package python-pyquery-1.2.4-1.el6:
* should fix your issue,
* was pushed to the Fedora EPEL 6 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=epel-testing python-pyquery-1.2.4-1.el6'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-EPEL-2013-11700/python-pyquery-1.2.4-1.el6
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2013-12-21 13:53:23 EST
python-pyquery-1.2.4-1.el6 has been pushed to the Fedora EPEL 6 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.