Bug 993441 - NSS needs to conform to new FIPS standard. [rhel-6.6]
Summary: NSS needs to conform to new FIPS standard. [rhel-6.6]
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: nss-softokn
Version: 6.5
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: rc
: 6.6
Assignee: Elio Maldonado Batiz
QA Contact: Hubert Kario
URL:
Whiteboard:
Depends On:
Blocks: 1070830 RHEL6.6FIPS140
TreeView+ depends on / blocked
 
Reported: 2013-08-06 00:04 UTC by Bob Relyea
Modified: 2014-10-14 05:02 UTC (History)
12 users (show)

Fixed In Version: nss-softokn-3.14.3-13.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 993443 1004102 (view as bug list)
Environment:
Last Closed: 2014-10-14 05:02:40 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:1378 normal SHIPPED_LIVE nss bugfix and enhancement update 2014-10-14 01:06:09 UTC

Description Bob Relyea 2013-08-06 00:04:07 UTC
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Bob Relyea 2013-08-06 00:06:56 UTC
Argg.... bugzilla took cr as an "ok let's create the bug... here.s the real description...


Description of problem:


( from the testing lab... )

just today and effective immediately there is a new IG published. This
new IG affects all user space libraries.

The self tests must be invoked by a .ctor entry: see
http://csrc.nist.gov/groups/STM/cmvp/documents/fips140-2/FIPS1402IG.pdf
page 116 (section 9.10).

It is from now on disallowed that the calling app invokes the init
function for executing the self tests. The self test functions must be
invoked with a void __attribute__((contructor)) function.

For the kernel module, the
self test must be invoked in the __init function -- I think that is the
case with the testmgr.



How reproducible:

Inspection.

Comment 5 Paul Wouters 2013-09-04 13:29:22 UTC
(In reply to Bob Relyea from comment #1)

> It is from now on disallowed that the calling app invokes the init
> function for executing the self tests. The self test functions must be
> invoked with a void __attribute__((contructor)) function.

So openswan must now call the test function? If so, can you tell me what to call?

Comment 6 Eric Paris 2013-09-04 14:32:58 UTC
This bug must also be used to make sure that a -fips subpackage is created.  not just the self test fix.

Comment 7 Bob Relyea 2013-09-04 17:59:44 UTC
Paul, No. The test function will be called by the OS at DLL load time. Applications don't need to do anything (This basically moves the test function from NSS_Init time to load time).

Comment 12 Tomas Mraz 2013-12-04 15:38:33 UTC
Actually the -fips subpackage will not be created. The FIPS mode tests should be based on this table:

                     | /etc/system-fips | no /etc/system-fips
---------------------+------------------+----------------------
kernel fips flag     |       enforce    |    no test/no fips
---------------------+------------------+------
no kernel fips flag  |       test       |    no test

test = verify checksums only
enforce = verify checksums & abort in case of failure

Comment 13 Bob Relyea 2014-03-24 23:17:41 UTC
To be clear, NSS implements the /etc/system-fips side of this equation, as NSS can be put in FIPS mode whether or not the system is in fips-mode

                   |             |
-------------------+-------------+
NSS db in FIPS     |    enforce  |
-------------------+-------------+
NSS db not in FIPS |    test     |
-------------------+-------------+

test = verify checksums (and POST) only
enforce = verify checksums (and POST) at load time, abort a init time if failed.

Comment 14 Tomas Mraz 2014-03-25 08:35:22 UTC
This is in conformance with FIPS requirements.

Comment 17 Bob Relyea 2014-04-22 21:11:38 UTC
fixed in nss-softokn-3.14.3-13.el6

Comment 22 errata-xmlrpc 2014-10-14 05:02:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-1378.html


Note You need to log in before you can comment on or make changes to this bug.