Bug 993445 - User can successfully upload a txt file that doesn't exist
User can successfully upload a txt file that doesn't exist
Status: CLOSED CURRENTRELEASE
Product: Zanata
Classification: Community
Component: Component-Logic (Show other bugs)
development
Unspecified Unspecified
low Severity medium
: ---
: 3.5
Assigned To: David Mason
Zanata-QA Mailling List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-05 20:26 EDT by Damian Jansen
Modified: 2015-01-26 18:27 EST (History)
2 users (show)

See Also:
Fixed In Version: 3.5.0-SNAPSHOT
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-26 18:27:58 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Damian Jansen 2013-08-05 20:26:46 EDT
Description of problem:
If, for whatever reason, a txt file is moved or deleted while an admin is in the process of uploading, the file is still created on the server sans content of the original file.

Version-Release number of selected component (if applicable):
Dev

How reproducible:
Easy always

Steps to Reproduce:
1. Have a txt file on system with some content, echo "Blah whatever" >testfile.txt
2. Sign in as admin/maintainer
3. Go to a project, project version
4. Go to Source Documents, select Upload Document
5. Click browse, navigate to and select the testfile.txt
6. With the Upload dialog still in view, move or delete the testfile.txt
7. Press Upload

Actual results:
File is uploaded. Downloading this file results in an empty file being received.

Expected results:
Transaction failed.

Additional info:
This seems to occur only on Chrome and with a specific set of profile settings in Firefox. Pressing Upload in Firefox seemingly has no action other than a page reload.
Comment 2 David Mason 2014-08-11 19:49:48 EDT
Since the multi-file upload dialog is only used in one of a few upload locations, I suspect that commit may not completely fix this issue. Am I mistaken about this?
Comment 3 Damian Jansen 2014-11-19 00:41:50 EST
I think the other instances are handled differently.

Note You need to log in before you can comment on or make changes to this bug.