Bug 993490 - require "rr" does not work due to missing VERSION file
require "rr" does not work due to missing VERSION file
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rubygem-rr (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Guillermo Gómez
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 992855 993286 993366 993368
  Show dependency treegraph
 
Reported: 2013-08-05 23:44 EDT by Mamoru TASAKA
Modified: 2013-08-28 17:29 EDT (History)
2 users (show)

See Also:
Fixed In Version: rubygem-rr-1.1.2-2.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-28 17:28:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mamoru TASAKA 2013-08-05 23:44:14 EDT
Description of problem:
$ ruby -e "require 'rr'"
/usr/share/gems/gems/rr-1.0.5/lib/rr/version.rb:3:in `read': No such file or directory - /usr/share/gems/gems/rr-1.0.5/VERSION (Errno::ENOENT)
	from /usr/share/gems/gems/rr-1.0.5/lib/rr/version.rb:3:in `<module:RR>'
	from /usr/share/gems/gems/rr-1.0.5/lib/rr/version.rb:2:in `<top (required)>'
	from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:51:in `require'
	from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:51:in `require'
	from /usr/share/gems/gems/rr-1.0.5/lib/rr.rb:90:in `<top (required)>'
	from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:116:in `require'
	from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:116:in `rescue in require'
	from /usr/share/rubygems/rubygems/core_ext/kernel_require.rb:122:in `require'
	from -e:1:in `<main>'


Version-Release number of selected component (if applicable):
$ rpm -q rubygem-rr
rubygem-rr-1.0.5-1.fc19.noarch

and same for rawhide

How reproducible:
100%
Comment 1 Mamoru TASAKA 2013-08-14 09:57:39 EDT
BTW current upstream version is 1.1.1.
As F-20 branch happens on 2013-08-20, if no response is received I will fix this issue at least by next Sunday (2013-08-18)
Comment 2 Mamoru TASAKA 2013-08-15 10:21:46 EDT
Because now this is affecting many components, I will fix this issue. 	
Guillermo, if something went wrong, please ask me.

By the way, please consider to update rr to 1.1.1 on rawhide (f20) (at least one package I maintain needs newer rr to upgrade)
Comment 3 Mamoru TASAKA 2013-08-15 10:25:33 EDT
... and will also fix F-19 and F-18.
Comment 4 Fedora Update System 2013-08-15 10:39:36 EDT
rubygem-rr-1.0.5-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/rubygem-rr-1.0.5-3.fc19
Comment 5 Fedora Update System 2013-08-15 10:40:08 EDT
rubygem-rr-1.0.5-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/rubygem-rr-1.0.5-3.fc18
Comment 6 Mamoru TASAKA 2013-08-15 10:52:00 EDT
rubygem-rr-1.0.5-3.fc20 is now in F-20 buildroot.
Comment 7 Fedora Update System 2013-08-15 19:26:55 EDT
Package rubygem-rr-1.0.5-3.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing rubygem-rr-1.0.5-3.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-14822/rubygem-rr-1.0.5-3.fc19
then log in and leave karma (feedback).
Comment 8 Vít Ondruch 2013-08-16 03:55:35 EDT
Thanks Mamoru for taking care of this.
Comment 9 Guillermo Gómez 2013-08-18 09:48:45 EDT
Im planing updating to next version asap, thanks Mamoru (btw, today is Sunday ;) )
Comment 10 Guillermo Gómez 2013-08-18 10:08:04 EDT
Sorry about delayed response...
Comment 11 Fedora Update System 2013-08-18 17:07:57 EDT
rubygem-rr-1.1.2-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/rubygem-rr-1.1.2-2.fc19
Comment 12 Fedora Update System 2013-08-18 17:37:27 EDT
rubygem-rr-1.1.2-2.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/rubygem-rr-1.1.2-2.fc18
Comment 13 Fedora Update System 2013-08-20 09:42:51 EDT
rubygem-rr-1.1.2-2.fc19,rubygem-test-unit-rr-1.0.3-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/rubygem-rr-1.1.2-2.fc19,rubygem-test-unit-rr-1.0.3-1.fc19
Comment 14 Fedora Update System 2013-08-20 09:45:00 EDT
rubygem-rr-1.1.2-2.fc18,rubygem-test-unit-rr-1.0.3-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/rubygem-rr-1.1.2-2.fc18,rubygem-test-unit-rr-1.0.3-1.fc18
Comment 15 Fedora Update System 2013-08-28 17:28:45 EDT
rubygem-rr-1.1.2-2.fc19, rubygem-test-unit-rr-1.0.3-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 16 Fedora Update System 2013-08-28 17:29:04 EDT
rubygem-rr-1.1.2-2.fc18, rubygem-test-unit-rr-1.0.3-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.