Bug 993515 - glusterfs can not support to create qcow2_v3 guest image with fuse bypass
glusterfs can not support to create qcow2_v3 guest image with fuse bypass
Status: CLOSED DUPLICATE of bug 1032904
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: qemu-kvm (Show other bugs)
7.0
x86_64 Linux
high Severity high
: rc
: ---
Assigned To: Kevin Wolf
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-08-06 02:02 EDT by Jun Li
Modified: 2013-12-06 07:46 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-06 07:46:54 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jun Li 2013-08-06 02:02:19 EDT
Description of problem:
If use fuse mount to create qcow3 image,it is successful.
If use fuse bypass or fuse mount to create qcow2 image, both are successful.
only qemu-img don't support to create qcow3 images with fuse bypass

Version-Release number of selected component (if applicable):
qemu-kvm and kernel version: 
qemu-kvm-1.5.2-2.el7.x86_64
3.10.0-4.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.# qemu-img create -f qcow2 -o compat=1.1 gluster://10.66.6.82:24007/gv0/RHEL-7.0.qcow3  20G
2.
3.

Actual results:
Formatting 'gluster://10.66.6.82:24007/gv0/RHEL-7.0.qcow3', fmt=qcow2 size=21474836480 compat='1.1' encryption=off cluster_size=65536 lazy_refcounts=off 
qemu-img: Header extension too large
qemu-img: gluster://10.66.6.82:24007/gv0/RHEL-7.0.qcow3: error while creating qcow2: Invalid argument


Expected results:
create sucessfully.

Additional info:
Comment 2 Ademar Reis 2013-12-06 07:46:54 EST

*** This bug has been marked as a duplicate of bug 1032904 ***

Note You need to log in before you can comment on or make changes to this bug.